Add dictionary to spell checker

Add dictionary to spell checker

8
NewbieNewbie
8

    Nov 29, 2017#1

    I'm trying to add the Spanish dictionary for spell checking Spanish HTML files. I went to this page: Spell Checker Dictionaries and installed the Spanish Dictionary using the Custom method and installed it in C:\Program Files\IDM Computer Solutions\UltraEdit\. I tried the default UltraEdit option first, but the installer couldn't find the folder. But when I go to the Dictionaries after restarting UltraEdit, I don't see the Spanish dictionary there.

    What do I need to do to get the Spanish dictionary for spell checker?

    6,624550
    Grand MasterGrand Master
    6,624550

      Nov 30, 2017#2

      I double clicked on Spanish.msi after downloading it, selected UltraEdit Directory (UEStudio Directory and Custom were the additional options) and the installer has automatically found out that I have 32-bit UltraEdit installed in non standard directory C:\Programs\UltraEd and installed the data files to C:\Programs\UltraEd\GNU\aspell\data and the dictionary files to C:\Programs\UltraEd\GNU\aspell\dict. Then I started UltraEdit, opened Advanced - Settings or Configuration - Spell checker - Dictionary and selected the dictionary es in the list. That's it.

      I suppose that you have installed 64-bit UltraEdit and the installers of the dictionaries were not updated to support also 64-bit UltraEdit (uedit64.exe registered in Windows registry instead of uedit32.exe) until now.

      In your case the directory C:\Program Files\IDM Computer Solutions\UltraEdit\GNU\aspell\data should contain the file es.dat. And the directory C:\Program Files\IDM Computer Solutions\UltraEdit\GNU\aspell\dict should contain the files es.multi, es.rws, espaol.alias, esponol.alias and spanish.alias.

      I suggest to open Windows Control Panel - Programs and Features, select in list Spanish Dictionary and Uninstall it. Then install the dictionary once again using again Custom and Browse to the directory containing uedit64.exe during the installation. This worked for me too.
      Best regards from an UC/UE/UES for Windows user from Austria

      8
      NewbieNewbie
      8

        Nov 30, 2017#3

        Okay, I figured out the problem. For some reason when I selected the path C:\Program Files\IDM Computer Solutions\UltraEdit, it kept putting Program Files(x86) as what I had chosen even though I didn't select that folder, I checked a few times and it still put the other one as the selection. So this time I went and checked that folder after I installed the files and sure enough had an IDM Computer Solutions folder there with UltraEdit\GNU\aspell\dict and that's all, then the Spanish files there. So I just copied them over to the other directory in Program Files and it worked. I can now select the Spanish dictionary.

        Only problem now is: How do I get it to show the red squiggly line under misspelled words?

        I checked Enable spell as you type under Configuration > Spell Checker > Miscellaneous and I have the Spanish dictionary (es) selected under Dictionary, and I restarted UE, but it still doesn't show the red squiggly line under the misspelled words.

        6,624550
        Grand MasterGrand Master
        6,624550

          Dec 01, 2017#4

          Reason for wrong dictionary installation and workarounds

          On double clicking on Spanish.msi (MSI = Microsoft Installer) msiexec.exe is started and opens the file Spanish.msi. The Microsoft Installer detects that the MSI file is designed for a 32-bit installation. This results in activating the Windows File System Redirector which redirects access to C:\Program Files to C:\Program Files (x86) even when the user explicitly browses to a subfolder in C:\Program Files. See also WOW64 Implementation Details and Registry Keys Affected by WOW64 for details on how Windows x64 handles x86 applications regarding environment variables, file system and registry accesses.

          I think, the Microsoft Installer does not make a good job in this case on user explicitly browsing or entering C:\Program Files\IDM Computer Solutions\UltraEdit\ and next modifying this path to C:\Program Files (x86)\IDM Computer Solutions\UltraEdit\ on closing the browse to folder dialog. I could see this wrong behavior too.

          One workaround I have found was using the short path for the program files folder. For this workaround it is necessary to first open a command prompt window and run the command dir C:\Progra* /AD /X to get displayed all program files folders on drive C: with their short names. On my 64-bit Windows the short name of C:\Program Files is C:\PROGRA~1 and the short name for C:\Program Files (x86) is C:\PROGRA~2. So during Custom installation of Spanish.msi I browsed to folder C:\Program Files\IDM Computer Solutions\UltraEdit\, but I modified Folder name to C:\Progra~1\IDM Computer Solutions\UltraEdit\ before closing the browse for folder dialog with a click on button OK. That tricks the file system redirector and the dictionary files are installed into the GNU\aspell subdirectory of 64-bit UltraEdit program files directory.

          Another, more difficult workaround is what you have done now. The dictionary files are installed with using Custom option to C:\Program Files (x86)\IDM Computer Solutions\UltraEdit\ although having selected folder C:\Program Files\IDM Computer Solutions\UltraEdit\. Then open in Windows Explorer started as administrator the folder C:\Program Files (x86), select folder IDM Computer Solutions containing only the subfolders UltraEdit\GNU\aspell with the installed dictionary files, cut that folder with Ctrl+X, navigate to C:\Program Files and paste there the folder with Ctrl+V. For completeness it would be also good to run regedit as administrator, open HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft, search for all occurrences of C:\Program Files (x86)\IDM Computer Solutions\UltraEdit and modify each found occurrence (value name or string data) to C:\Program Files\IDM Computer Solutions\UltraEdit. That registry modification is not really necessary, but results in a correct uninstall of the installed dictionary when this is ever done in future via Control Panel - Programs and Features.

          Using spell checking on typing on syntax highlighted files

          After having enabled at Advanced - Settings or Configuration - Spell checker - Miscellaneous the setting Enable spell as you type and configured the other settings in this dialog, the spell checking on typing is enabled for non syntax highlighted files, i.e. plain text files.

          For syntax highlighted files containing code which should be ignored by the spell checker, some additional settings are necessary. For HTML files it is recommended to navigate in configuration to Spell check - Filters, enable Use filters and select HTML or Automatic detection. The options at Spell check - Ignore options might be also set according to spell checking requirements.

          Additionally it is necessary for spell checking syntax highlighted files on typing to explicitly enable that feature in the used syntax highlighting wordfile(s). So open Advanced - Settings or Configuration - Editor Display - Syntax highlighting. Select the installed wordfile HTML if not already selected because active opened file is already highlighted with this wordfile, and click on button Open. Other wordfiles could be also opened now like the wordfile for PHP. Then close the configuration dialog with Cancel (or OK if some configurations were modified before). In the opened wordfile(s) insert in first line left to File Extensions = the case-sensitive keyword EnableSpellasYouType, save and close the wordfile(s).

          This enables spell checking on typing for files syntax highlighted with the modified wordfile(s).
          Best regards from an UC/UE/UES for Windows user from Austria

          8
          NewbieNewbie
          8

            Dec 01, 2017#5

            Thank you so much for your detailed answer. For the Spell Check, I followed your instructions and have the things checked in Configuration. I also added the keyword EnableSpellasYouType to the html.uew wordfile. Here is the first line with that added:
            /L3"HTML" HTML_LANG Nocase Noquote Block Comment On = <!-- Block Comment Off = --> EnableSpellasYouType File Extensions = HTM HTML SHTML HTT HTA HTX CFM JSP PHP PHTML ASP TMPL ASAX ASHX ASMX ASPX ASCX
             I added to the left of File Extensions = like you said, but I still don't see it working. Did I add it in the right spot in the wordfile?

            6,624550
            Grand MasterGrand Master
            6,624550

              Dec 01, 2017#6

              Yes, EnableSpellasYouType is added at right position in the wordfile html.uew.

              Do you have opened the wordfile via the syntax highlighting configuration dialog to open the right wordfile?

              html.uew in C:\Program Files\IDM Computer Solutions\UltraEdit\wordfiles would be the wrong wordfile. The right wordfile with default configuration would be in %APPDATA%\IDMComp\UltraEdit\wordfiles as opened via the syntax highlighting configuration dialog.

              Or do you have an additional *.uew file in the wordfiles directory used by UltraEdit which is responsible for highlighting HTML files?

              I hope the answer on this question is no because that would cause not really working syntax highlighting of HTML files.

              Or do you have a project opened with a project specific wordfile configured in the project settings?

              In this case it would be necessary to edit the project specific wordfile.

              I tested the spell checking on typing on a *.html file opened in 32-bit UltraEdit v24.20.0.44 with my preferred installation location and later also with 64-bit UltraEdit v24.20.0.44 with default installation location as on your computer (extra installed) with English, German and Spanish dictionaries installed and also used one of the other in both UltraEdit on the opened HTML file. Enabled spell checking as you type worked in all 6 test cases as expected. The filter was enabled with HTML selected.
              Best regards from an UC/UE/UES for Windows user from Austria

              8
              NewbieNewbie
              8

                Mar 29, 2018#7

                Mofi, I'm replying on this thread because it's a similar problem I'm having with the Spanish dictionary. My UltraEdit got upgraded and after the upgrade I could not see the Spanish dictionary. So I uninstalled and reinstalled it again but still cannot find it. It is in the correct folder, all the files are there, but in Advanced Settings under Spell Checker > Dictionaries, I don't see the Spanish dictionary. Not sure what is going on.

                6,624550
                Grand MasterGrand Master
                6,624550

                  Mar 30, 2018#8

                  Starting with UltraEdit v25.00 and UEStudio v18.00 the spell checking is done on Windows 8/8.1 and Windows 10/11 using the Windows Spell Checking API instead of Aspell which is used further only on Windows 7.

                  Microsoft wrote the support articles Language packs and Language packs are available for Windows 8 and for Windows RT with the instructions on how to install additional language packs.

                  I don't have any computer running Windows 8, Windows 8.1 or Windows 10 at the moment. So I cannot help with even more detailed instructions on how to use spell checking in UltraEdit v25.00 on Windows 8 and later Windows versions with multiple languages.
                  Best regards from an UC/UE/UES for Windows user from Austria

                  8
                  NewbieNewbie
                  8

                    Mar 30, 2018#9

                    Thanks for the info. So I added the Spanish language pack to Windows and now I can switch to the Spanish dictionary in UltraEdit, but still cannot get it to spell check correctly. It has ALL of my Spanish text file underlined in red. But I am using Windows 10 and UltraEdit v25.00. Do you know where I could check as to how to get this to work?

                    6,624550
                    Grand MasterGrand Master
                    6,624550

                      Mar 31, 2018#10

                      Sorry, I cannot help further as I am using Windows 7 and still Windows XP. Please contact IDM support by email and ask for help on this issue.

                      It would be good to post here additional information for other users of UltraEdit v25.00 once having solved the issue with help of IDM support.
                      Best regards from an UC/UE/UES for Windows user from Austria

                      11
                      Basic UserBasic User
                      11

                        2:08 - Apr 08#11

                        I have UltraEdit x64 v.30.2.0.41, installed on path C:\Program Files\UltraEdit. I try to install English spell checker "English.msi" to path C:\Progra~1\UltraEdit. OK, it's created folder C:\Program Files\UltraEdit\GNU\aspell with some subfolders and data. But in Menu - Advanced - Configuration... I can't find option Spell checker. And I don't understand how to turn on spell check?

                        6,624550
                        Grand MasterGrand Master
                        6,624550

                          6:24 - Apr 08#12

                          There is no support anymore for spell checking with Aspell since UltraEdit for Windows v28.10 which means no spell checking support anymore on using such an UltraEdit version on Windows 7. The installation of the Aspell English dictionaries with "English.msi" is useless for that reason with UltraEdit v30.2.0.41 64-bit. The Aspell dictionaries should be uninstalled as not used anymore. There is used since UE v28.10 on Windows the Windows spell checking API. There must be installed the suitable Windows language pack for usage of the spell check feature in UltraEdit on Windows 8/8.1/10/11.

                          I use English UltraEdit v30.2.0.41 64-bit on an English 64-bit Windows 11 and installed additionally the Windows German language pack to have the option using the dictionaries de-AT, de-CH, de-DE, de-LI, de-LU in addition to en-CA, en-LR, en-PH, en-US and my personal dictionary.
                          Best regards from an UC/UE/UES for Windows user from Austria

                          11
                          Basic UserBasic User
                          11

                            12:30 - Apr 08#13

                            Yes, I understand. Thank you!