Auto-complete options filter

Auto-complete options filter

11
NewbieNewbie
11

    Apr 14, 2021#1

    In previous versions I used to click Ctrl+Space to open the auto-completion window and smart templates were on the top of the list. So I could use them instantly.
    Now I get some weird suggestions. I don't know where they come from, they aren't related neither to the project nor to my wordfile.

    How do I fix it?

    Toggling off IntelliTips didn't change it. The second imageshows how far gone my desired autocomplete options.

    auto-completion_ultraedit_28_00.png (3.85KiB)
    Auto-completion window in UltraEdit for Windows v28.00
    auto-completion_prior_ultraedit_28_00.png (3.61KiB)
    Auto-completion window in versions of UltraEdit prior v28.00

    6,602547
    Grand MasterGrand Master
    6,602547

      Jun 05, 2021#2

      There is a misunderstanding regarding to the configuration settings at Advanced - Settings or Configuration - Auto-complete - Miscellaneous. The check box settings IntelliTips suggestions, language keywords and auto-complete text belong to the check box setting Show auto-complete dialog automatically. So the three check box settings define which sources are used in the auto-completion window shown automatically on typing a string.

      The auto-completion window opened manually by pressing Ctrl+Space makes always use of all sources: syntax highlighting wordfile, function list, auto-complete file (on being one configured), words found in current file above current caret position and symbols found by IntelliTips symbol parser (on being enabled).

      The list of suitable templates in automatically or manually opened auto-completion dialog window depends on the configuration setting Include templates in auto-complete dialog at Advanced - Settings or Configuration - Templates.

      There is only the option to uncheck Enable IntelliTips at Advanced - Settings or Configuration - Auto-complete - IntelliTips - Advanced if the symbols found by IntelliTips symbol parser like the functions (fx) should not be listed in the manually opened auto-completion window. Otherwise there is only the option to make use of the automatically opened auto-completion window with having the check box setting IntelliTips suggestions unchecked in configuration.
      Best regards from an UC/UE/UES for Windows user from Austria