Auto save on file opened without temporary file not on all character inserts

Auto save on file opened without temporary file not on all character inserts

3
NewbieNewbie
3

    Oct 12, 2015#1

    Hi,

    I use UEStudio version 15.20.0.7.

    I have disabled auto saving files.
    If I type any alphabetic or numeric character then the file will be saved immediately.
    But if I type German umlauts or special character like # * % then the file is not saved immediately!?

    Whats wrong?

    Cheers
    Mike

    6,626551
    Grand MasterGrand Master
    6,626551

      Oct 12, 2015#2

      Do you have selected Open file without temp file but NO Prompt at Advanced - Configuration - File Handling - Temporary Files?

      This should be only selected when using UltraEdit/UEStudio nearly exclusively for viewing and editing large files as without usage of a temporary file any edit is done directly on stored file without any buffer and also undo is not possible.

      Use Use temporary file for editing (normal operation) or Open file without temp file but prompt for each file and configure a suitable threshold value.
      Best regards from an UC/UE/UES for Windows user from Austria

      3
      NewbieNewbie
      3

        Oct 12, 2015#3

        Hi,

        yes now it works.

        The problem is, I often work with large files (more then 1 GB) and I often work with small files.
        Why does UES save this files immediately "only" when I type alphabetic or numeric character and not when I type special chars?

        I just want to save the file when I click on save button :)

        I think the bug is either it is saving by typing any char OR it is not saving by typing special chars ;)
        I prefer the first one :D

        Cheers Mike

          Oct 12, 2015#4

          Hi again,

          i found the problem.
          If I change the setting (file size) to more then 0 KB in Advanced - Configuration - File Handling - Temporary Files then it is working fine…

          i have send a mail to support to fix this ;)

          Cheers Mike

          6,626551
          Grand MasterGrand Master
          6,626551

            Oct 12, 2015#5

            Mike, you are right with your observation of immediate save not done for any modification on file opened without usage of a temporary file. Non ASCII letters/digits inserted by the user are not immediately written to file which is the case on any file opened without usage of a temporary file independent on threshold value. That's really interesting and of course unexplainable for users.

            The threshold value is just useful to open by default small files with usage of a temporary file and just large files without usage of a temporary file. The default value 0 sets threshold internally to 50 MiB (50 * 2^20 bytes = 52428800 bytes = binary 50 MB).

            The dialog displayed on opening a file having a file size equal or larger the threshold value depends on selection in configuration.

            Use temporary file for editing (normal operation)
            temporary_file_handling_1.png (3.93KiB)
            Message on large file with use temporary file for editing (normal operation)

            Open file without temp file but prompt for each file
            temporary_file_handling_2.png (2.94KiB)
            Message on large file with open file without temp file but prompt for each file

            Open file without temp file but NO Prompt

            No message displayed when large file is opened without usage of a temporary file.

            This option should be used only when working mainly with large files.
            Best regards from an UC/UE/UES for Windows user from Austria