Backup FTP files locally

Backup FTP files locally


    Dec 07, 2015#1


    I have activated FTP backups in "Advanced --> Configuration --> File Handling", but it only creates the a folder structure. No FTP files appears to be backed up. Locally edited files are backed up as expected. Only FTP causes me headaches.

    Remote server = Ubuntu 12.04
    OS = Windows 10 (Upgraded from fresh windows 7 install)
    UE Version = installed AFTER Windows 10 got upgraded.

    Backup options:
    • Backup files on save = Append .BAK
    • Default backup directory (local) = Is set and working as expected
    • On save = Checked
    • On automatic save = Checked
    • On FTP save = Checked
    • Default FTP backup directory = Is set but encounter above mentioned issue.
    • Format = $b$p$n($c)$e
    • Max. number of backups = 25
    Also note that I've experimented setting a local backup directory within the FTP account itself but no difference. My understanding is doing this only overrides the settings in UE's main configuration which behaves as expected, but still no files backed up on save.

    This used to work flawlessly on previous combinations of UE and Windows so anything I might be missing or doing wrong?


    Power UserPower User

      Dec 07, 2015#2

      Well, here is what I have:

      I do not have the On FTP save checked. I do not have a default FTP backup directory set.

      However, under my default backup directory UE made several directories that match my FTP account names (which I make sure have the machine name in them so they are different for the several servers I use). Under these directories there are directory trees that match my path on the remote machine and there are current backups stored there - despite my not having the On FTP save checked. I have maximum number of backups set to 6, but this does not seem to affect the FTP backups as I only have the most recent saved file without prior versions. Also, only files that I saved while in UE are there - just viewing the files does not make a local backup.


        Dec 08, 2015#3

        I've tried removing the FTP default path as well. Unchecking "On FTP save" behaves just as I understand it, nothing happens anymore including where I have specified UE to save backups of locally edited files. In short, no more directory tree matching the remote path location on the server gets created. Re-enabling the "On FTP save" and specifying again the same directory I had at first, and boom ! Remote path structure gets replicated but here's the weird thing this time...

        Disabling the option then re-enabling it did appeared to fix the problem...

        Everything is exactly the same as it was when I first tried it. Only difference is the time for a meal in between the 2 attempts to make it work (about an hour or so...)

        As a side note, it appears IDM still haven't added versioning capability for remote files... Such a nice piece of software without this simple feature. Would be soooo... simple to implement.

        Anyway, it appears all behaves as expected now except versioning for remote files...

        Thank for the feedback !