Borland C ++ in 2006 error message

Borland C ++ in 2006 error message


    Oct 20, 2011#1

    I have a giant problem with UEStudio version 11.x in German.

    I try to integrate Turbo C ++ in 2006 professional the debugger.

    I have gone forward as follows:

    1. Project creates
    Put on menu Project → project according to template.
    Borland Inprise compiler → Win32 Console Application clicked.
    Configuration rework → right page [variable]
    Under [variable]
    CPATH: C:\Program Files\Borland\BDS\4.0\Bin
    COPT: With COPT I have changed nothing. If this is so right or I must change there something.
    If so what I must act?

    Then I am to [Environment]

    I have tried out it once so:
    PATH = $ (CPATH) \Bin; %PATH %
    INCLUDE = $ (CPATH) \Include

    And I have tried out it once so:
    PATH = $ C:\Program Files\Borland\BDS\4.0\Bin; %PATH %
    INCLUDE = $ C:\Program Files\Borland\BDS\4.0\Include
    LIB =/L $ C:\Program Files\Borland\BDS\4.0\lib/L $ C:\Program Files\lib\psdk

    What I'm doing wrong?

    Then I have on configuration save clicked afterwards on OK.

    Then I have clicked in the menu on construction on compiler paths.
    With Inprise of compilers C/C ++ I have entered:
    C:\Program Files\Borland\BDS\4.0\Bin
    Then I have clicked on closing.

    Then I have clicked on construction and following output is indicated:
    Configuration, hello-Debug
    Fatally: File LIB.OBJ cannot be opened.
    Hallo.exe-1Fehler, 0 warnings

    What must I do with it I can create my project?
    Please help me!! :cry:


    Grand MasterGrand Master

      Oct 21, 2011#2

      Well, I don't have Borland Inprise Compiler. I just have the very, very old 16-bit DOS Turbo C++ compiler of Borland from 1991 for which the configurations Turbo C Compiler and Turbo C++ Compiler are available in UEStudio.

      For your version of the Borland C++ compiler either Borland C++ Compiler or Borland Inprise Compiler must be chosen. I can't tell you which one, but it looks like Borland C++ Compiler configuration is for 16-bit DOS applications and therefore very similar to Turbo C++ Compiler configuration while Borland Inprise Compiler is for 32-bit console and Windows applications.

      I can see in the configuration that Borland Inprise Compiler is designed for version 5.5 of Borland C++. So if you use version 4.0 it could be that some options are not working.

      While the path of many modern compilers can be found by UEStudio in registry of Windows, this is not possible for the Borland Compilers. That's the reason why the configurations for the Borland Compilers contain in the [Variables] section the definition of CPATH. The value of this variable can be modified directly using Build - Select Compiler - Edit Configuration, but that should not be done because UEStudio offers a special Compiler Paths dialog opened with Build - Set Compiler Paths for those compilers of which the compiler's path can't be found in registry.

      In Compiler Paths dialog you have to set the path for Inprise C/C++ to C:\Program Files\Borland\BDS\4.0 and on closing the dialog with button Close, UEStudio updates all CPATH variables of all configurations of the compilers displayed in the dialog including the 4 configurations for Borland Inprise Compiler.

      So after this configuration you should see in the compiler configuration


      CPATH =C:\Program Files\Borland\BDS\4.0

      As you can see in the configuration the value of variable CPATH is referenced several times with $(CPATH) (without any space!), especially in section [Environment] where PATH for executing the compiler, INCLUDE for the standard include files and LIB for the standard libraries are defined. As you can see in your C:\Program Files\Borland\BDS\4.0 directory there should be a Bin subdirectory with the compilers executables, an Include subdirectory with the standard *.h header files and the subdirectory Lib with the subdirectory PSDK.

      What could be a problem in your configuration is the space character in path to Borland C++ directory. If possible install the compiler to a directory not containing a space character, for example install it to C:\Compilers\Borland\BDS\4.0

      As you can see it is not really possible to define in Compiler Paths dialog the path to the compiler with double quotes because of the space character in path. That would work for

      CPATH ="C:\Program Files\Borland\BDS\4.0"

      but would result in wrong definition of PATH, INCLUDE and LIB.

      Alternatively you could open a command prompt window, for example with executing CMD.exe, and use command DIR C:\ /AD /X to see all directories with short 8.3 and long name.
      With knowing the 8.3 name for C:\Program Files\Borland\BDS\4.0 which is probably C:\Progra~1\Borland\BDS\4.0, you can define the compiler path in Compiler Paths dialog with this path to avoid a possible problem because of the space character in path.

      Of course you could also modify the configuration and use on the right places double quote characters. But you would need to read the manual if /L... with a space character in path must be defined as "/L..." or as /L"...". Much easier is to avoid a compiler path with a space character inside.

      By the way: Variables are referenced by $(VariableName). There should be no additional spaces. And when you use the path strings directly in the configuration which I do not recommend, then without the $ sign. Always take into consideration how the line would be executed from within a command prompt window.

      $ C:\Program Files\Borland\BDS\4.0\Include is definitely a not correct line because Windows reads here as first parameter $, as second parameter C:\Program and as third parameter Files\Borland\BDS\4.0\Include because the space character is the separator for the parameters, except when a space is inside a double quoted string.


        Oct 21, 2011#3

        Thank you very much. :D :D