Can the font be changed in UltraCompare?

Can the font be changed in UltraCompare?

221
Basic UserBasic User
221

    Sep 14, 2023#1

    Hello,
    I see a "Set Font dialog" mentioned in the UltraCompare Help Index, but I can't see how to activate it from menu or ribbon.

    The default font does not make a good job of displaying combining diacritic characters.  In UltraEdit I use the Consolas font without any problems.

    Thank you.

    1029
    Power UserPower User
    1029

      Sep 15, 2023#2

      From the menu interface, go to View - Themes - Manage Themes.  You are then presented with the Manage Themes dialog from which you can set your preferred fonts.

      If you use ribbon mode go to the Layout tab, and select Themes - Manage Themes.

      UC themes.png (76.33KiB)
      Manage Themes dialog window of UltraCompare

      Cheers,
      Frank

      221
      Basic UserBasic User
      221

        Sep 15, 2023#3

        Thanks, Frank, but unfortunately changing the text font to Consolas didn't fix the combining diacritic positioning in UC after all.

        If I use UC's "Save Result Report" to plain text and read it into UE, it's fine  (displaying it with Consolas — not fine with Courier New)!

        So it is looking like some inconsistency between UC and UE rather than simply a font issue.

        6,606548
        Grand MasterGrand Master
        6,606548

          Sep 15, 2023#4

          UltraCompare and UltraEdit use the same code to display text. It would help us to help you if you post an example of two compared text files or even better compress two compared text files into a 7-.Zip, RAR or ZIP archive and attach the archive file to your next post using Full Editor & Preview button here in the forum. There should be attached also a screenshot of the UltraCompare window created by pressing left Alt+PrtSc and pasting the image data into Microsoft Paint which is saved next as PNG file (lossless compression). Are the characters not displayed fine supported by Consolas at all or is UltraEdit using a different font to get these characters displayed as UltraEdit automatically does if a character in a Unicode encoded file is not supported by the configured font.
          Best regards from an UC/UE/UES for Windows user from Austria

          221
          Basic UserBasic User
          221

            Sep 15, 2023#5

            Thank you. I hope these attachments will be sufficient.

            An example is the word "амё̀боци́т"  This contains a precomposed "ё" (unicode hex U+0451) followed by a combining grave accent (U+0300).
            UEConsolas.png shows it correctly displayed in UE (v.26.10.0.82) – the file test.txt is utf8 encoded.
            UECourierNew.png shows the same file with the font changed to Courier New. The acute accent is placed over the wrong character. I'm not bothered about this. I assume the problem is with the font.

            Now to UC (v.2022.20.0.42).  There is no problem (as far as I can see) with the comparison operation, but only with the display of the text.  I compare the file with one (test1.txt) where the word is "амѐбоци́т" — "е" (U0435) followed by combining grave.  In both files, the grave is shown over the wrong character. This happens whether the font is Consolas or CourierNew.

            As I mentioned before, if I use UC's "Save Result Report" to plain text and read it into UE, it displays fine (with Consolas font in UE).

            Perhaps UC is "normalising" the accents before comparison, and not undoing it properly before display? If I compare test.txt with itself, there is no need to normalise, and everything shows correctly.
            UCCourierNew.png (25.89KiB)
            UCConsolas.png (25.58KiB)
            UECourierNew.png (30.3KiB)
            UEConsolas.png (29.76KiB)
            +1
            test1.txt (32 Bytes)   0
            test.txt (32 Bytes)   0

            6,606548
            Grand MasterGrand Master
            6,606548

              Sep 16, 2023#6

              I cannot reproduce a wrong display of амё̀боци́т м 1а and амѐбоци́т м 1а with using Consolas version 5.22 with 32-bit English UltraEdit version 2023.1.0.23 and 32-bit English UltraCompare version 2023.0.0.30 as well as UltraCompare version 2022.20.0.45 and 2022.20.0.26 restored from my archives on 64-bit English Windows 7 with Austria configured as country for my account. I see the same display issue as you with using Courier New version 5.11. Please see the attached images. I updated also Courier New to version 6.92 and Consolas to version 7.00 on Windows 7 by copying the eight TTF files from Windows 11 22H2 and installing them on Windows 7 and could not see any difference neither for Consolas nor for Courier New. I have not archived UltraCompare version 2022.20.0.42. It looks like I missed this version of UltraCompare.
              UC_2023_0_Consolas.png (15.65KiB)
              Display of the two text files in UltraCompare 2023.0.0.30 with Consolas
              UC_2023_0_CourierNew.png (15.19KiB)
              Display of the two text files in UltraCompare 2023.0.0.30 with Courier New
              UE_2023_1_Consolas.png (12.16KiB)
              Display of the two text files in UltraEdit 2023.1.0.23 with Consolas
              UE_2023_1_CourierNew.png (10.26KiB)
              Display of the two text files in UltraEdit 2023.1.0.23 with Courier New
              +1
              Best regards from an UC/UE/UES for Windows user from Austria

              221
              Basic UserBasic User
              221

                Sep 17, 2023#7

                Thank you for taking the trouble to make those tests.

                The problem I observed with UC 2022.20.0.42 and Consolas was also present with my older versions of UC 18.00.0.45 and 18.00.0.86 (all 64-bit).
                Your tests show that it was fixed as early as 2022.20.0.26 (32-bit).

                Version 2022.20.0.42 was not a distributed version but was sent to me as a resolution of another problem, around 2022/12/21. I can only guess that it was based on a distributed version earlier than 2022.20.0.26 and thus inadvertently reverted some earlier fixes.  Or, if it was based on the latest distributed version at the time, that in solving my problem it reintroduced the present problem.

                Anyway, the solution is for me to upgrade UC, though I'm not planning to do that in the foreseeable future.

                Thank you again.

                6,606548
                Grand MasterGrand Master
                6,606548

                  Sep 17, 2023#8

                  I restored UltraCompare version 18.00.0.45 from my archives and compared the two text files with that version. Now I could see the grave accent in both file panes above fourth character б instead of third character ё respectively e. That was important to know for me. I updated UC next from my archives to version 18.00.0.47 and the display issue remained. I updated once more to version 18.00.0.62 and the text display became correct. UltraCompare 18.00.0.80 and 18.00.0.86 showed the text also correct in both file panes using Consolas version 7.00 on Windows 7.

                  I looked in my archive of hotfix information published by UltraEdit, Inc. for all UltraCompare 18.00 versions and could not see an explicit note about a fix of this text display issue. But the published hotfix information contained also several other minor issues addressed and this display issue is definitely a minor issue for a comparison tool. However, the wrong display of the text is definitely fixed in currently latest UltraCompare and definitely also in several former versions.

                  It is impossible for me to find out on which version is based on the non-public published version 2022.20.0.42. You could send an email to support of UltraEdit, Inc. and ask for EXE installer or MSI file depending on current version installed with EXE installer or MSI file for UltraCompare 2022.20.0.45 in language X If the purchased license is for UltraCompare 2022.20 to have finally installed a public version of UltraCompare with a fix of this text display issue on using Consolas.
                  Best regards from an UC/UE/UES for Windows user from Austria

                  221
                  Basic UserBasic User
                  221

                    Sep 18, 2023#9

                    Thanks once again.
                    My licence wouldn't cover a free upgrade to 2022.20.0.45, but I may consider a paid upgrade to the latest version of UC.
                    Just for the record, UC 18.00.0.86 on my Windows 10 system shows the problem (see attachment).
                    UC18.00.0.86Consolas.png (54.29KiB)

                      Sep 27, 2023#10

                      Just an update.  I obtained the latest version of UC (23.0.0.40, 64-bit), and am still getting the problem.  So I'm getting it with every version of UC I have tried, including the latest one.  There must be a reason why Mofi's system and mine are behaving differently, so I have contacted UE support now, and will report back here when there is some news.