Command Line Macro - Search string not found!

Command Line Macro - Search string not found!

6
NewbieNewbie
6

    Oct 20, 2004#1

    I'm trying to run a macro from the command line to delete recurring sections of a file by having it repeat 10,000 times. Currently it's not exiting UE because the message window comes up stating: Search string not found!. Is there a way to make this macro automatically exit back to the command line?

    UEDIT32 gh.xml /M,E,10000="bidshift.MAC/remove1500"

    remove1500 macro commands:
    InsertMode
    ColumnModeOff
    HexOff
    UnixReOff
    EndSelect
    Find "<start-time>1500</start-time>"
    EndSelect
    Key UP ARROW
    Key UP ARROW
    Key UP ARROW
    Key UP ARROW
    Key HOME
    StartSelect
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key DOWN ARROW
    Key END
    EndSelect
    Key DEL

    6,605548
    Grand MasterGrand Master
    6,605548

      Oct 21, 2004#2

      You have to modify the macro and the macro properties. Enable in the macro properties (Macro - Delete Macro/Modify Properties) "Continue if a Find with Replace not found". Then edit the macro to this version.

      InsertMode
      ColumnModeOff
      HexOff
      UnixReOff
      Loop
      Find "<start-time>1500</start-time>"
      IfFound
      EndSelect
      Key UP ARROW
      Key UP ARROW
      Key UP ARROW
      Key UP ARROW
      Key HOME
      StartSelect
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key DOWN ARROW
      Key END
      EndSelect
      Key DEL
      Else
      ExitMacro
      EndIf
      EndLoop

      You now don't need the 10000 counter anymore at the command line, because the loop in the macro runs as long as the search string is found.
      Best regards from an UC/UE/UES for Windows user from Austria

      6
      NewbieNewbie
      6

        Oct 21, 2004#3

        :D

        Thank you Mofi! That worked perfectly.