Ctags not working for project, Create CTAG File disabled in Project (solved)

Ctags not working for project, Create CTAG File disabled in Project (solved)


    Feb 20, 2016#1

    Ctags is not working for my project. I have enabled it in the project, specified a location for the ctags file and configured the file to be created on project open.

    No ctags file is being created and both the 'Create CTAG File' selection in the Project menu and the 'Find Symbol' selection in the Search menu are disabled.

    I cannot find any option in configuration that seems to have any bearing on this.

    Here is version information from Help | About

    UltraEdit Professional Text/HEX Editor (x64)

    Grand MasterGrand Master

      Feb 21, 2016#2

      I'm using 32-bit UE v22.20.0.49 on Windows XP and Ctags works fine for C/C++ projects.

      What is configured in Project - Ctag Options?

      The Ctag EXE path/name should be with default installation for 64-bit UE: C:\Program Files\IDM Computer Solutions\UltraEdit\GNU\ctags.exe

      The standard Ctag parameters are: -L %fi -f %fo

      I don't know how to get the menu item Create CTAG File in menu Project displayed disabled as even with no project opened and no file opened this menu item is enabled in 32-bit UE v22.20.0.49 on Windows XP. A Ctag file can be created also for active file only if no project is loaded which is the reason why this menu item is always enabled.

      Ah, wait a moment. If Default tag file does not contain path and name of a file, the menu item Create CTAG File is disabled even if a project is loaded which contains in project settings a valid path and name for the project ctag tag file overriding the default tag file specification.

      So please specify a Default tag file in Project - Ctag Options to enable the Ctags support.
      Best regards from an UC/UE/UES for Windows user from Austria