Cut and Paste pastes something like Chinese

Cut and Paste pastes something like Chinese

2
NewbieNewbie
2

    Oct 18, 2021#1

    Hi,

    I don't know if this is an UltraEdit problem or problem with Apple's Messages utility on my iMac. But if I type the following into UltraEdit:

    Code: Select all

    what the heck?
    Then select that text copy and paste it into an apple Messages chat window, it comes out like this:

    Code: Select all

    眀栀愀琀 琀栀攀 栀攀挀欀㼀
    If I paste it into an email, it comes out fine.
    If I paste the "what the heck?" (that I typed into UltraEdit and copied from UltraEdit) into Notes or Pages, it pastes as "what the heck?".
    So, I'm guessing this is a pages problem, however, if I copy text from email, notes, pages, pretty much anything except UltraEdit into a Messages message, it comes out fine.  Only UltraEdit text pastes screwy.

    How can I get UltraEdit back to pasting regular text into messages?

    Thanks,
    Brad

      Oct 18, 2021#2

      Okay - seems to be a Big Sur problem - MacOS Big Sur iMessage Pasting Shows Kanji Characters.

      Damn it - I keep all my notes in UltraEdit and paste them into all kinds of things. Can't believe Messages has a problem like this. But Command+Option+Shift+V works okay. but that's hardly fun to do every time.

      Anyway - if anyone has experienced this and has a solution, please let me know.  

      Thanks,
      Brad

      Mofi
      6,567530
      Grand MasterGrand Master
      6,567530

        Oct 19, 2021#3

        It helps perhaps to convert the file with the notes from ASCII/ANSI (character encoding using one byte per character with a code page) to Unicode with using encoding UTF-8 or UTF-16 LE. Then UltraEdit loads the file with using two bytes per character in memory and copies the selected strings also in Unicode to the clipboard, i.e. with two bytes per character instead of just one byte per character.

        Please note that on using Unicode encoding UTF-8 there must be at least one non-ASCII character in your notes file which is encoded with more than one byte in stored file or the notes file is saved with UTF-8 BOM (byte order mark). If the Unicode encoding UTF-8 is used by you as storage encoding for the file and the file contains only ASCII characters and the UTF-8 encoded file is stored without BOM at top of the file, the file is binary identical to the ASCII encoded notes file and for that reason UltraEdit would load the file next time again as ASCII encoded file. The usage of UTF-16 LE encoding with BOM is most likely the best for the notes file as in this case UltraEdit can detect the Unicode encoding very quickly by analyzing just the first two bytes of the file and can very quickly load the rest of the file as no analyzing of each byte is necessary as on using UTF-8.
        Best regards from an UC/UE/UES for Windows user from Austria