Disable macro on startup

Disable macro on startup

2
NewbieNewbie
2

    19:37 - Feb 05#1

    I created a macro and set it to load on startup. I no longer needed the first macro because I incorporated it into a second macro, so I deleted the first macro. However, now I get a macro load error on startup. How can I remove the reference to the first macro on startup (UE version 28.10)?

    6,649559
    Grand MasterGrand Master
    6,649559

      10:06 - Feb 06#2

      I think, you mean with macro a macro file. A macro file can contain multiple macros.
      • In ribbon mode click on last ribbon tab Advanced in third group Macro on the small down arrow symbol right to the item Configure and click next in the opened popup menu on the menu item Set macro for auto-load.
      • In toolbar/menu mode with contemporary menus click in menu Advanced in submenu Configure on the menu item Set macro for auto-load.
      • In toolbar/menu mode with traditional menus click in menu Macro on the menu item Set auto load...
      In the opened dialog window Set Macro Auto Load on Startup delete the macro file name or use the Browse button and select the macro file which contains now the often used macro(s) and then click on button Set.

      Don't wonder on opening this dialog window a second time after deletion of the macro file name that the deleted file name is replaced now by the full path of the directory configured at Advanced - Settings or Configuration - Directories with the setting Default macro directory. That does not matter as a directory path is not enough. There must be configured the fully qualified file name of a macro file to be loaded on startup of UltraEdit and not just the full name of a directory containing one or more macro files.

      The entire section [MacroAutoLoad] is removed from the configuration file %APPDATA%\IDMComp\UltraEdit\volatile\ue.vod on deletion of the macro file name in the dialog window, clicking on button Set and exiting UltraEdit.
      Best regards from an UC/UE/UES for Windows user from Austria

      2
      NewbieNewbie
      2

        18:28 - Feb 09#3

        Snap, I didn't even notice the right arrow drop down with the options. I've always just clicked on the main button. Your instructions solved the issue. Thank you!