File Open dialog doesn't show hidden files (solved)

File Open dialog doesn't show hidden files (solved)

3
NewbieNewbie
3

    Jul 11, 2014#1

    I have a problem with UEX v4.2.0.5 on a Linux Mint system: The "File Open" dialog (local, not FTP) doesn't show dot (i.e. hidden) files.
    Besides this, it seems that the "Find in files" command also ignores them.
    AFAIK the configuration does not include an option to control this behavior but maybe I've overlooked it...

    Any suggestions?

    6,626551
    Grand MasterGrand Master
    6,626551

      Jul 11, 2014#2

      I'm using only UltraEdit on Windows, so can't help with a verified answer.

      In one answer on What are dot-files? there is the hint to right click into the window resulting in opening a context menu item with a menu item for showing hidden files. It could be that this method works also in UEX.

      Perhaps pressing Ctrl+H while File Open window is displayed toggles visibility of hidden files like in other Linux text editors.

      On Windows it is possible to enter in file name edit field for example *dlg*.cpp, hit key RETURN and get now listed only files with extension CPP containing string dlg. That is a common Windows feature. Perhaps Linux supports also such a dynamic filtering. Try entering .* as file name, hit key RETURN and look if the list of displayed files changes.
      Best regards from an UC/UE/UES for Windows user from Austria

      3
      NewbieNewbie
      3

        Jul 11, 2014#3

        Thanks for your hints - both CTRL+H and the context menu option solves the problem :)

        But the Find/Replace In Files command still ignores dot files...

        6,626551
        Grand MasterGrand Master
        6,626551

          Jul 12, 2014#4

          UEX power tip about using find, replace, find in files, and replace in files does not contain any information about searching in hidden files, i.e. files starting with a dot in name.

          Either find/replace in hidden files is really not possible which I don't think, or it is not documented.

          In UltraEdit for Windows running a Find in Files with an empty search string results in listing just the file names with full path as a result. I suggest to try that also in UEX - run a Find in Files with an empty search string and experiment with various In files/types wildcards like just * or .*

          If the files starting with a dot are not listed on all attempts, hopefully another UEX user can help and post here the solution. Or you ask IDM support by email if find/replace in hidden files is possible at all on Linux using UEX.
          Best regards from an UC/UE/UES for Windows user from Austria

          3
          NewbieNewbie
          3

            Jul 12, 2014#5

            Thank you again...
            I've tried various wildcard patterns, but none of them works :(

            I think, asking IDM will probably be the best solution...