File opened via SFTP won't upload to SFTP server successfully on save on using a relative path (solved)

File opened via SFTP won't upload to SFTP server successfully on save on using a relative path (solved)

2

    Sep 21, 2022#1

    Hello,

    I'm trying to edit some files over an SFTP connection, and I'm getting some weird behaviors.
    I'm using the currently latest version 2022.1.0.100 of UltraEdit.
    I added an SFTP account to the account manager, than I can connect through the File Explorer.
    I then double click a file to open it. works like a charm.
    I try to edit that file, but when I wanna save it with "Ctrl+S" the red arrow is staying red, telling me it didn't save it.
    The only way I found to save my file is to go to "Home->FTP->Save to FTP".
    In the window that opens, I click "connect", it says I'm connecting, yet I get stuck with the lightning sign saying "reading directory".
    If I disconnect, and then click on the green refresh arrow, it then connects to my server, but to the root of my username, instead of the directory I'm working in.
    If I then move myself to the appropriate directory, I can overwrite my file, and after that, everything will work fine. I can Ctrl+S to save my file over SFTP, until I try a new file...

    Thanks for any help.

    Mofi
    6,48846632
    Grand MasterGrand Master
    6,48846632

      Sep 21, 2022#2

      I do not use the FTP/FTPS/SFTP feature of UltraEdit and cannot really help for that reason. I recommend to read from power tips page the power tips Configure FTP and Configure FTP backup and Link to remote directories and Shared FTP accounts.

      There can be enabled also under Advanced - Settings or Configuration - FTP the configuration setting Show FTP log in output window and make visible the output window with the tabs FTP Transfers and FTP Log. These two tabs should be viewed by you to find out what is going on in background and why the automatic upload to the server does not work on save. It could be that something is not correct configured for the SFTP server in the account settings in FTP Account Manager window. There must be perhaps enabled the account setting Enable Keep Alive on tab Server to periodically send a signal to the SFTP server to avoid that the server disconnects after a period of inactivity from the server´s point of view while the downloaded file is edited in UltraEdit.
      Best regards from an UC/UE/UES for Windows user from Austria

      2

        Sep 26, 2022#3

        I found the problem and could solve it.
        For some reasons, there must be configured the absolute path in the FTP account manager and not the relative for the user.
        So for instance, there can't be set as default directory public_html even on user is automatically rooted to that directory in user´s home directory.
        There must be the full path /home/user1/public_html configured in the SFTP account settings.
        I hope hat can help future users.

        Mofi
        6,48846632
        Grand MasterGrand Master
        6,48846632

          Oct 02, 2022#4

          Thank you for the information. I have not often used the FTP/FTPS/SFTP feature of UltraEdit, but that is indeed curious. It looks like an error in configuration of the SFTP server. If the SFTP server automatically redirects each directory listing to the home directory of a user on the server according to the user name used on establishing the SFTP connection, it should also redirect every file read/write access to the user´s home directory and interpret all directory/file paths relative to the user´s home directory. I have never read before that on client side must be used the absolute path on the server.
          Best regards from an UC/UE/UES for Windows user from Austria