How do you make it so opening a new file/tab always places the new file/tab at the end of all tabs?

How do you make it so opening a new file/tab always places the new file/tab at the end of all tabs?

3
NewbieNewbie
3

    May 02, 2021#1

    I re-installed UltraEdit on a new PC and whenever I open a new file, it puts it at the BEGINNING of my list of tabs. This is weird. It used to always put it at the end.

    NOTE: I am using v22.0.0.66

    Thanks!

    6,602547
    Grand MasterGrand Master
    6,602547

      May 03, 2021#2

      Right click on any file tab to open the context menu, open the submenu File Tabs and make sure the option Sort File Tabs is not enabled by clicking on this menu item if this option is currently enabled.
      Best regards from an UC/UE/UES for Windows user from Austria

      3
      NewbieNewbie
      3

        May 03, 2021#3

        Mofi wrote:
        May 03, 2021
        Right click on any file tab to open the context menu, open the submenu File Tabs and make sure the option Sort File Tabs is not enabled by clicking on this menu item if this option is currently enabled.
        Thank you so much. That helped a bit.

        Oddly, the Sort file tabs option doesn't have a check box. But by clicking it once that seems to have "turned off" this feature. :)

        But it doesn't really solve the problem. It works for like one NEW FILE, but if I actually OPEN a specific, existing file, it still puts it at the beginning/front of all file tabs instead of at the end.

        This is very frustrating. It never worked like this before when I was using the exact same version (and copied my config/ini files from old PC to new PC).

        ALSO: Any time I try to manually move file tabs myself, it is REALLY difficult. It is like they are being snapped back into some other location as if UltraEdit is trying to sort them itself and so by doing it manually I am fighting against this.

        Thanks!

        6,602547
        Grand MasterGrand Master
        6,602547

          May 04, 2021#4

          I restored temporarily UltraEdit v22.00.0.66 and tried to reproduce the behavior of opening a file with file tab being shown as first tab on open file tabs bar. I could not reproduce this behavior. Please let us know following configuration settings from Advanced - Configuration - Application Layout - File Tabs - Operation:
          • Dockable tabs checked or unchecked
          • Types with Single line -scrollable or Single line - drop down file list or Mulitline selected
          • Close tab button with None or On tab bar or On active tab or On all tabs selected
          Best would be you attach the INI file to your next post of which full file name is shown at  Advanced - Configuration - Application Layout - Advanced at bottom. Then I could use your configuration on my computer with UE v22.00.0.66 to check if there is the same file tabs behavior on my computer with your configuration and find out which setting is responsible for this behavior if reproducible by me with your configuration. I am not aware about any setting to get the file tab of an opened file added on file tabs bar to the left with the exception of the configuration setting Sort tabs on file open which can be toggled also via the file tabs context submenu item Sort File Tabs.
          Best regards from an UC/UE/UES for Windows user from Austria

          3
          NewbieNewbie
          3

            May 05, 2021#5

            Configuration settings from Advanced - Configuration - Application Layout - File Tabs - Operation:

            file_tabs_operation_settings_ue_22_00.png (16.45KiB)
            Settings in File Tabs - Operation of UltraEdit v22.00

            The initially attached UltraEdit INI file was deleted after Mofi downloaded and analyzed it.

            6,602547
            Grand MasterGrand Master
            6,602547

              May 05, 2021#6

              Thanks for the information of the configuration settings and the INI file. I could reproduce the issue with your settings / INI file. The cause of the unexpected behavior is the configuration of a multiline open file tabs bar, but the open file tabs bar display is currently defined to use not more than one line. In this case the file tab of a newly opened file is displayed on left side if there are multiple files already opened of which file tabs occupy already the entire line.

              Here are the steps to define a greater maximum height to get more lines of file tabs displayed on being necessary because of many files opened in UltraEdit.
              1. Please open first enough files to have more files opened as the open file tabs bar with a single line can show at once, i.e. when the file tab of the next opened file is displayed on left side of the file tabs bar.
              2. Then right click on any file tab, open the submenu File Tabs and click on first context submenu item Dockable.
              3. Now move the mouse pointer over the area between the file tabs bar and the document window of active file. The mouse pointer changes to a symbol with two short horizontal lines with up and down arrows.
              4. Press and hold the left mouse button and drag and drop the bottom border of the open file tabs bar downwards and leave the mouse button.
                The maximum open file tabs bar height defined by this action determines how many lines are used in future by UltraEdit to display file tabs.
                Note: UltraEdit automatically uses only the vertical space from the defined maximum height which is currently needed for the file tabs of the opened files. So if all file tabs fit into one line, there is only one line of file tabs displayed and the rest of the vertical space up to the status bar at bottom is used for the document windows. But if there are lots of files opened, UltraEdit uses more lines to show the file tabs until the maximum height defined by the user with that action is reached in which case no more lines are added and new file tabs are displayed in the top/left corner of the multiline file tabs bar. A user defined maximum height for the open file tabs bar is necessary on having really many files opened at once like 50 files or even more to be able to see nevertheless the window of active file. So don't increase the height of the open file tabs bar up to the status bar at bottom. That would be no good idea.
              5. Finally right click once again on any file tab,  open the submenu File Tabs and click once more on first context submenu item Dockable to toggle it off.
              Now on opening a file of which file tab does not fit anymore into the first line of the multiline tabs bar with an increased maximum height defined by the user, UltraEdit increases the height of the file tabs bar for one more line and displays the file tab of just opened file at end which is in the second line of the file tabs bar and the document window area is decreased accordingly.
              Best regards from an UC/UE/UES for Windows user from Austria