How get separator within double quoted value interpreted as literal character on table compare?

How get separator within double quoted value interpreted as literal character on table compare?

5
NewbieNewbie
5

    Jul 20, 2017#1

    When I compare two .CSV files, UltraCompare does not properly recognize fields defined in quotes which may contain commas. It separates the data in the field based on the comma(s) instead of treating it as a single field. Is there some way to adjust this?

    JohnD

    6,600547
    Grand MasterGrand Master
    6,600547

      Jul 20, 2017#2

      I have never used this feature of UltraCompare before. But I could see now that you are absolutely right. Interpreting the data in CSV files is not complete according to basic rules as described on Wikipedia page about comma-separated values. I can't see any session property or general configuration option to change this.

      Please send an enhancement request email to IDM support to get in a future version of UltraCompare a CSV table comparison interpreting a separator within a double quoted field value as literal character, a double quote escaped with a double quote inside a double quoted field value as double quote and also line breaks within double quoted field values correct.
      Best regards from an UC/UE/UES for Windows user from Austria

      5
      NewbieNewbie
      5

        Jul 21, 2017#3

        Thanks, enhancement request sent.

        JohnD