How to avoid automatic horizontal scrolling when selecting a line with cursor?

How to avoid automatic horizontal scrolling when selecting a line with cursor?

2

    Aug 09, 2021#1

    Hello!

    I'm hoping someone can help me out with something that has been driving me nuts for years with UltraEdit. It has finally bothered me enough that I've made a forum account to see if one of the great community members can help me find the setting that controls this. I can't be the only one.

    Allow me to explain...

    When I am working on a long line of code/text that has caused my horizontal scroll to move right, I need to be ultra careful not to touch any area of the editor above or below that particular line, if I do, the horizontal scroll moves immediately back to the left and I'm forced to re-scroll back right to find where I was and continue doing what I was doing. 

    Is there a way around this? Or at least to not allow this to happen?

    I understand if it didn't do this my cursor could in theory end up out of my visible area, which is probably why this happens. But I'm wondering if anyone has found a way around this? I dread every time I have to edit long lines of code as I know I will be screwing around with the horizontal scroll, highlighting with the mouse amplifies this 10 fold.

    I've attached a screenshot to help indicate what I'm trying to get to you.

    Thanks!
    very_long_code_line.png (86.44KiB)
    The image shows the end of a very long code line.

    6,602547
    Grand MasterGrand Master
    6,602547

      Aug 10, 2021#2

      Open Advanced - Settings or Configuration - Editor display - Cursor / caret and check the configuration setting Allow positioning beyond line end.
      Best regards from an UC/UE/UES for Windows user from Austria

      2

        Aug 10, 2021#3

        Thank you so much! That worked perfect!!!