How to configure the appearance of the open file tabs bar in UE v15.00 and later?

How to configure the appearance of the open file tabs bar in UE v15.00 and later?

1
NewbieNewbie
1

    Apr 17, 2009#1

    First of all, congratulations to 15 years of IDM and one of the best editors ever.

    That said, the v15.00 GUI is a major step back regarding usability. The "new" Open Files tab is not usable anymore - just open up a few files (try like 50), and your entire screen will be blocked by the open files toolbar. Where are those tiny [<] and [>] buttons from earlier versions? And why does that toolbar even need a caption title bar which takes up unnecessary extra space?

    It's so annoying to work with I had to downgrade to v14... :cry:

    Is there a way to get the old, not so shiny v14 theme back into v15?

    119
    Power UserPower User
    119

      Apr 17, 2009#2

      Side scrolling tabs are still an option. Open the configuration dialog and go to Application Layout - File Tabs - Operation. In the Types section select Single line -- scrollable. To get rid of the "Open Files" titlebar clear the Dockable tabs check box.

      6,632551
      Grand MasterGrand Master
      6,632551

        Apr 17, 2009#3

        There is also quick access to all the file tabs options, if you don't use customized popup menus. Click with right mouse button on any open file tab. A context menu appears with the menu item File Tabs. Move the mouse pointer over this menu item and a submenu opens with all the file tab options for quick selecting.

        filetaboptions.png (11.06KiB)
        Screenshot of the file tab options context submenu.

        And on wide screen displays with much higher width than height it could be better to use the dockable open files tab bar docked on right or left side instead of top with multiline tabs and perhaps additionally auto hided, see attached screenshot.

        The state of the option dockable determines the document interface. With dockable document windows respectively file tabs the classic Windows MDI (multi-document interface) is used which makes it possible to use the classic Windows MDI features like minimizing a document window and position respectively arrange them in any order and any size anywhere. And with dockable file tabs the classic Windows MDI commands Tile Horizontal and Tile Vertical are also available which simply do nothing else than resizing and repositioning all not minimized document windows to get them vertically or horizontally arranged within the application's main client area.

        As disabling showing the open file tabs bar for example by clicking on View - Views/Lists - Open File Tabs is possible only with dockable document windows, UltraEdit switches to the dockable document windows interface without changing the configuration setting for dockable file tabs on disabling the open file tabs bar. Therefore disabling or closing the bar with title Open Files enables the classic Windows MDI commands Tile Horizontal and Tile Vertical, too.

        The other multi-document interface is the undockable file tabs interface which is active if the Open File Tabs bar is enabled and the Dockable option is not enabled. With this document interface the tiling commands in menu Window are not available and therefore grayed out. But also this interface supports arranging files side by side vertically or horizontally by dragging and dropping a file tab.

        There are two power tips of IDM among lots of other useful tips and hints which should be read by an UltraEdit or UEStudio user interested in customization of the file tabs appearance or wanting to know how to arrange document windows side by side:
        After reading those 2 power tips there should be no misunderstanding anymore regarding document window interface.

        Last there was the command Enable tiling / Dockable tabs added to menu Window with UltraEdit v19.10 and UEStudio v13.10 most likely because there are a lot of users who disable Dockable window for removing the Open Files bar and wondering why the commands Cascade, Tile Horizontal, Tile Vertical, Arrange Icons and Minimize All Windows are greyed out now and therefore it looks like it is not possible to arrange two files side by side for a visual compare although this is also possible with not dockable file tabs by using the drag and drop method.
        open_file_tabs_view_docked_on_right_side.png (36.65KiB)
        Dockable multiline open file tabs bar docked on right side with auto hide.

        119
        Power UserPower User
        119

          Apr 17, 2009#4

          Mofi wrote:There is also quick access to all the file tabs options
          Ah, they cleaned that up. I had squawked about it during the beta but didn't re-check the context menu after seeing that they'd consolidated things in the configuration dialog.

          4
          NewbieNewbie
          4

            Jun 24, 2009#5

            I am having trouble that my file tabs do not show at all, the tabs are suddenly gone. I followed these instructions, but I still don't get the file tabs even after multiple files are open. Is there another configuration to enable them?

            6,632551
            Grand MasterGrand Master
            6,632551

              Jun 24, 2009#6

              There are lots of options to customize the open file tabs bar. Independent of the look, the open file tabs bar can be enabled/disabled via View - Views/Lists - Open File Tabs like in UE < 15.00. It can be disabled also by clicking on the small X in top right corner of the bar when using the dockable version. Some users click by mistake on the X of the bar instead of the X above for the file. A simple solution to avoid this is to use Ctrl+F4, a double click on the tab of the file or a middle button click on the file tab for closing a file. Using the not dockable version of the open file tabs bar removes not only some space - the line with Open Files, it removes also the X of the tabs bar and the file which avoids closing the bar instead of the file.

              And of course it is possible to undock the open file tabs bar and let them display in a floating window which is maybe out of the visible area or below another window. In this case the menu item View - Views/Lists - Recover Floating windows should help.

              With UE v15.10 the user must confirm closing the Open File Tabs bar when clicking on the X symbol of the dockable bar in the top right corner. That should help avoiding of closing the bar by mistake instead of the active file.

              And with UE v17.30.0.1011 and later the X symbol on Open Files title bar closes not anymore the Open File Tabs view, it closes now the active file if configuration setting MDI close button closes active file (not file tabs) is enabled as by default at Application Layout - File Tabs - Miscellaneous.

              For a more complete instruction on how to get back a suddenly lost open file tabs bar see the topic I lost / undocked the Open File Tabs bar / view.

              2

                Sep 01, 2009#7

                Hello,

                is there a way to get rid of the popup infos for the file tabs? I find them annoying when I compare small files quickly by switching back and forth. Couldn't find any configuration setting for this, I'm using v15.10.

                6,632551
                Grand MasterGrand Master
                6,632551

                  Sep 01, 2009#8

                  LietIbmaSad wrote:Is there a way to get rid of the popup infos for the file tabs?
                  There is no configuration setting to disable the file information displayed as tooltips. Write an enhancement request email to IDM support.

                  Addition on 2011-06-03: Since UltraEdit v17.10.0.1008 it is possible to disable the tooltips of the file tabs by once right clicking on a file tab and unchecking File Tabs - Show Tooltips.

                  For comparing files, use File - Compare Files, or arrange the windows of the files to compare horizontally or vertically, or switch between the files with the keys Ctrl+F6 (Next Window) and Ctrl+Shift+F6 (Previous Window), or using Ctrl+Tab (with Ctrl+Shift+Tab to revert order for Ctrl+Tab), or using Alt+Down Arrow (Next File Tab) and Alt+Up Arrow (Previous File Tab).

                  2

                    Sep 02, 2009#9

                    I know, but clicking the tabs is the fastest way for me to see whether a single line has changed or not, especially when I have more than two files. I think I can get along with the Alt+Down/Up combination. Thanks for your reply.

                    2
                    NewbieNewbie
                    2

                      Sep 10, 2009#10

                      I'm sorry to ask, but I just can't find it...
                      How do I configure UE to default to the File Tabs view?

                      Thanks for any help!

                      6,632551
                      Grand MasterGrand Master
                      6,632551

                        Sep 10, 2009#11

                        Once the file tabs are enabled they are visible, except you clicked on the symbol to auto-hide the file tabs which is only possible using dockable tabs. If the open file tabs bar is set to auto-hide itself, move the mouse pointer over Open Files to see the bar, move the mouse right in the title line of this bar which shows Open Files and click on the middle symbol on the right side to toggle auto hide mode for this bar to state off. You can also click with the right mouse button on the title line of the Open Files bar and click on Auto Hide on the context menu. Or you click on the small down arrow symbol on right side of the Open Files title bar which also opens the context menu where you can click on menu item Auto Hide to disable it.
                        Best regards from an UC/UE/UES for Windows user from Austria

                        2
                        NewbieNewbie
                        2

                          Sep 10, 2009#12

                          Thank you - I must have had auto hide enabled.

                          1581
                          Power UserPower User
                          1581

                            Aug 18, 2013#13

                            Mofi wrote:...Addition on 2011-06-03: Since UltraEdit v17.10.0.1008 it is possible to disable the tooltips of the file tabs by once right clicking on a file tab and unchecking File Tabs - Show Tooltips...
                            In Version 19 this feature seem to be removed .. The help says: "The tooltip is displayed."

                            Peter

                            6,632551
                            Grand MasterGrand Master
                            6,632551

                              Aug 18, 2013#14

                              The option to toggle display of file tab tooltip still exists in UE v19.10.0.1012 as I wrote and works. There is no change in comparison to version 17.10.0.1008 on which this option was introduced.

                              You may not see it in your File Tab popup menu as this menu is customizable. Therefore it can be that you either use a customized non standard environment/layout already for a longer time and UltraEdit does never update profile files of a custom environment/layout, or you denied after an upgrade the update of the menu profile files.

                              Open View - Environments (UE prior v20.00) or View - Layouts - Manage Layouts (UE v20.00 and later) and click on button Reset Built-In Environments respectively Reset Built-In Layouts. You should first save your currently used customized environment/layout before using this button to reset the built-in environments/layouts.

                              Alternatively it is possible to reset just the menu (main menu and customizable popup menus) and toolbar profiles of built-in environments/layouts selectively. Open Advanced - Configuration - Toolbars / Menus - Management, click on button Manage Toolbars or Manage Menus, select the built-in toolbar / menu to reset and click on button Reset.

                              1581
                              Power UserPower User
                              1581

                                Aug 18, 2013#15

                                Mofi wrote:...Therefore it can be that you either use a customized non standard environment/layout already for a longer time and UltraEdit does never update profile files of a custom environment/layout, or you denied after an upgrade the update of the menu profile files...
                                Yes, I believe that's the reason. I found it and restored it, thanks again.

                                Peter