How to merge a single line of text and not the whole block?

How to merge a single line of text and not the whole block?

2
NewbieNewbie
2

    Jan 10, 2017#1

    Hello,

    I am a network engineer and all of the configurations for our networking devices are saved as text files. We use a standard template for most of our devices, but there are a lot of changes that need to be made.

    I am having difficulty just changing one line from the text_a to text_b. Instead it changes the whole block. I have tried using the line mode merge without much luck. I have also tried the advanced merge only to have the whole block changed.

    Does anyone know of a way to do a compare and only change one line at a time?

    Any help will be greatly appreciated.

    Thanks!

    6,605547
    Grand MasterGrand Master
    6,605547

      Jan 11, 2017#2

      The merge mode Line Mode Merge (Ctrl+J) in menu Merge on using toolbar/menu mode must be enabled to merge a single line from first to second or from second to first.

      Additionally a single line must be selected in both panes by clicking on the line to merge in both panes. In the attached screenshot merge_single_line_first_to_second.png the line to merge has a yellow background color in both panes.

      It is also possible to merge a single line from second to first file or vice versa which is at a different position in file as the attached screenshot merge_single_line_second_to_first.png demonstrates where line 5 from second file is merged to line 7 in first file.

      The lower half on both screenshots shows the result after the single line merge.
      merge_single_line_first_to_second.png (19.57KiB)
      This screenshot shows how to merge line 6 from first file to line 6 in second file.
      merge_single_line_second_to_first.png (20.17KiB)
      This screenshot shows how to merge line 5 from second file to line 7 in first file.
      Best regards from an UC/UE/UES for Windows user from Austria

      2
      NewbieNewbie
      2

        Jan 13, 2017#3

        Thank you so much. I was missing clicking on the second pane. This is going to save me a lot of time!