How to start UltraEdit maximized on Windows 10?

How to start UltraEdit maximized on Windows 10?

2
NewbieNewbie
2

    Apr 03, 2019#1

    Hi, I can't get UltraEdit to start maximized under Windows 10. The window icon on the top right shows as maximized (the two squares) but it's not. There is a space of a few pixels wide on the sides and bottom. When I minimize the window and then maximize it again it is fully maximized. 

    I tried all the usual tips for Windows 10 like setting the shortcut properties to run as maximized, closing the application with the Ctrl key, and deleting the shortcut and creating a new one but nothing helps so far.

    6,632551
    Grand MasterGrand Master
    6,632551

      Apr 05, 2019#2

      UltraEdit main application is opened by default as it was on last exit which means as normal window with a user defined size and position or maximized. This is controlled by the values stored with WindowPos= by default in file uedit32u.in0 or uedit64u.in0 in directory %APPDATA%\IDMComp\UltraEdit.

      So there is something wrong on your computer or another process prevents UltraEdit on starting with a maximized main application window if starting UltraEdit maximized does not work on your computer on UltraEdit being exited last time with a maximized window.

      I suppose you are using 64-bit UltraEdit for Windows ≥ v24.00 running on Windows 10 version 1809 for everything written below. Let me know if you are using 32-bit version or an older version of UltraEdit or a different version of Windows.


      I suggest first to exit all instances of UltraEdit and rename the file uedit64u.in0 for example to uedit64u_bak.in0 in directory %APPDATA%\IDMComp\UltraEdit. Copy and paste this path into address bar of Windows Explorer and hit key RETURN or ENTER to open this directory in Windows Explorer. I recommend also deleting all uedit64.* files without u left to file extension. These are ANSI encoded configuration files of UltraEdit < v24.00 no longer used by UltraEdit for Windows ≥ v24.00 using the Unicode encoded configuration files. And delete also all uedit32.* files from 32-bit UltraEdit on using now 64-bit UltraEdit. Now start UltraEdit which sets the workspace to default based on used layout, maximize the UltraEdit main application window, exit UltraEdit and restart it.

      Does it start maximized as on exit?

      Yes, the problem is solved with recreating the workspace file. Delete file uedit64u_bak.in0 and reconfigure the workspace to the layout you like.

      No, exit UltraEdit, delete just created file uedit64u.in0 and rename file uedit64u_bak.in0 back to uedit64u.in0 to restore your preferred workspace.


      My second suggestion is opening Advanced - Settings or Configuration - Application layout - Window state and toggle configuration setting Always open editor maximized. This setting is not checked by default. The usage of this setting is better than setting to Run Maximized in properties of shortcut used to start UltraEdit. It is better to configure in properties of shortcut file UltraEdit.lnk to Run with Normal window and use this UltraEdit configuration setting.

      Does it make a difference on starting UltraEdit on having configuration setting Always open editor maximized checked/unchecked?

      Are other settings checked in configuration dialog Window state?

      Is a project/workspace always opened on exit of UltraEdit? Yes, is configuration setting Close all files when opening or switching projects checked or unchecked at Advanced - Settings or Configuration - File handling - Miscellaneous?


      My third suggestion is opening Windows Task Manager by right clicking on Windows task bar at bottom and clicking in context menu on task manager menu item. Select the tab Startup and look on list of all processes (executables) started by Windows on startup of Windows.

      Do you know what all these processes are for? Is there a process which is an application window manager?

      There is usually installed with video adapter (graphic card) driver additional software not really needed to get displayed the graphic windows. One of those applications started on Windows startup offers global hotkey support for example to rotate screen most people never use. Another one offers to change resolution or graphic settings quickly via a symbol in system tray also not used ever by most people. And there could be installed also an application window manager which detects start of an application and sends a message to the just started application to switch to a configured window mode, window position and window size. Please find out if such an application window configuration management software is running on your computer. You can uncheck processes you don't know what they are doing on Startup tab of Windows task manager and restart Windows to see if there is a change on those unknown processes are not running on starting UltraEdit.


      My last suggestion is compressing entire directory %APPDATA%\IDMComp\UltraEdit into a 7-Zip, RAR or ZIP archive file while no instance of UltraEdit is running and add this archive file containing your entire UltraEdit configuration as attachment to your next post. Then I could look into it and test what happens on using your configuration on my computer with Windows 7 SP1 x64. I don't have a computer running Windows 10.
      Best regards from an UC/UE/UES for Windows user from Austria

      2
      NewbieNewbie
      2

        Apr 05, 2019#3

        Thank you for the thorough reply. I tried all of your suggestions, but unfortunately it didn't fix the problem. I did some more research and found it was related to the Windows setting Show shadows under windows as described here: How to Disable the Drop Shadows in Windows 10. After disabling the setting the space around the window is gone. However I don't know why this setting only affected UltraEdit and not any other application I've used.