I lost / undocked the Open File Tabs bar / view

I lost / undocked the Open File Tabs bar / view

1

    Aug 25, 2004#1

    Hi,

    playing around with the dockable menu bars resulted in not having the file tabs menu bar anymore. Regardless of selecting/deselecting View - Views/Lists - Open File Tabs the tabs bar is gone. Could anyone please help me?

    Best regards,
    Peter

    6,645558
    Grand MasterGrand Master
    6,645558

      Nov 21, 2004#2

      The following is only for UltraEdit versions 9.00 - 10.20d !!!

      First select Open File Tabs from View - Views/Lists. If you can see now the file tabs, nothing more to do.

      If not, the file tab is floating anywhere undocked. Close UltraEdit, minimize all windows and restart UltraEdit. Look at your screen, if you can see the file tab anywhere. Double click on the file tab title bar do dock it again.

      If all this solutions do not help. Close UltraEdit and open Uedit32.ini with Notepad and set

      [Settings]
      ControlBarsFromReg=0

      Start UltraEdit and the file tab should be visible. Close UltraEdit again and set ControlBarsFromReg back to 1 in Uedit32.ini with Notepad, if you want that UE saves the settings in the registry, which is default.


      The following is for versions of UltraEdit from v11.00 to v13.20a !!!

      Since v11.00 the menu configuration is not stored anymore in the registry or in the INI (uedit32.ini) as in previous versions. The menu configuration is now saved in an ASCII DOS file with the extension .mfg in the same directory as the INI (uedit32.ini) currently used. And it is possible to have more than 1 menu configuration (files).

      By default during installation or update/upgrade always 2 menu configurations (and toolbars *.tfg and pop-up menus *.pfg) are created and updated by UltraEdit: Basic.mfg and Advanced.mfg. Every user can also create its own configuration stored with a different name which should be done when the user wants to make many modifications.

      If you have the Advanced menu and the open file tabs are gone, click on View - Views/Lists - Open File Tabs.

      If you have the Basic menu and the open file tabs are gone, you first have to switch temporarily or permanently to the Advanced menu. Click with the secondary (right) mouse button on the menu bar and select Advanced from the pop-up menu. Then you can enable the open file tabs as described above.

      63
      Advanced UserAdvanced User
      63

        Mar 16, 2006#3

        Hi Joe

        I hope this fixes it and it's this easy!

        Pull down menu View - Views/Lists - Open File Tabs
        This is a toggle, so it's ON or OFF.

        Depending on your version of UltraEdit you might notice down at the bottom of the menu the menu entry Disable Workspace Close Buttons. If you don't want to loose your TABS by accident again, you can check this.

        If this doesn't fix it, it means the "File Tabs" are floating around and that can be a tricky fix.

        Good Luck

        1
        NewbieNewbie
        1

          Dec 03, 2006#4

          It looks like I have lost my open file tabs and I can't get them back.

          How do you get the file tabs to show. Somehow I turned them off, and I can't figure out how to get them to display again.

          After clicking on Open File Tabs (from the view lists), it puts a floating box with 2 lines: File, then 2 line, the tabs. But it either overlays the toolbar or the file.

          This isn't what it looked like before. It used to display the tabs without overlaying any other information.

          How do I fix this?

          6,645558
          Grand MasterGrand Master
          6,645558

            Dec 08, 2006#5

            Your Open File Tabs view is undocked. Simply double click with primary (left) mouse button on the title bar of the Open Files window, not the UltraEdit main window. The title bar is the bar at top of the window with text "Open Files" and the small x button. Then the view will be docked again.

            If View - Views/Lists - Open File Tabs does not bring the file tabs back and you can't see it when you have all edit windows closed in UE, try first to move the main UltraEdit window nearly completely out of the screen. Maybe you can then see the window and double click on it's title bar to dock it again. If you still can't see it, then do following:

            While UE is not running create 2 copies of uedit32.ini.

            Then edit copy 1 of uedit32.ini with UE or with Notepad.

            Search for Floating=1.

            I hope, you find it only once in a group named like [ToolBarState1-v110-Barx].

            Delete that group, save the copy 1 of uedit32.ini, close UE and copy the modified file over existing uedit32.ini. Then start UE again and hopefully the file tab bar is back docked, if it was the only floating bar. If not, use copy 2 to restore original uedit32.ini and copy 1 and delete the other bar which is floating.

            1
            NewbieNewbie
            1

              Jun 08, 2007#6

              We have also been experiencing this problem. It would seem that the problem is related to having multiple displays. When I set my desktop to only be on one monitor then it is possible to find the floating open files bar. Otherwise, the bar is nowhere to be found.

              LarryD

              7
              NewbieNewbie
              7

                Oct 02, 2007#7

                LDorman wrote:We have also been experiencing this problem. It would seem that the problem is related to having multiple displays.
                I just went through this. I have also multiple displays on a laptop which I frequently undock. The tabs got lost from some stray clicking near the tab bar...I'm not sure exactly what I did.

                I tried all the obvious things and steps suggested in this thread, except for editing the uedit32.ini file, with no luck.

                So then I edited uedit32.ini, as Mofi described, and found two sections named like he described, and two other floating=1 sections named quite differently. Being lazy and not wanting to do that twice, I nuked both sections at once. I actually renamed them from ToolBarState1-v110-Bar15 to ZZZZZZZ-ToolBarState1-v110-Bar15 so I could undelete easier if needed.

                This did the trick.

                Thanks again, Mofi.

                -dave

                14
                Basic UserBasic User
                14

                  Oct 08, 2007#8

                  I too have a laptop I use with multiple displays & had this problem. I tried the .ini edit, and it did not seem to work. Then I undocked the laptop and started it up disconnected (so the only display was the laptop's). I started UE, closed all doc window and *still* didn't see the floating file tabs toolbar.

                  Then on a lark, I changed my windows taskbar properties to 'auto-hide', and when it hid itself I could *then* see the floating file tabs toolbar way at the bottom of the UE window. A quick double-click and all was well.

                  Cheers,

                  -Roy

                  2
                  NewbieNewbie
                  2

                    Jan 27, 2009#9

                    I just had this problem and had to take 20 minutes to fix it. I was just about to give up and, if I hadn't seen the simple advice to double click on the floating icon, I may never have had my file tabs again. From all the posts here, it looks like it's a common enough problem that someone should think about re-designing it. It should be a simple matter to either show it or hide it and to either dock it or undock it using two simple toggle switches, and both toggle switches ought to be accessible from the 'View' menu. Why does it need to be any more complicated than that? Should I really have to dig through a .INI file just to see my file tabs?

                    Sorry if this sounds like a rant. I really just mean it as a suggestion. UE is a fabulous product precisely because it's so easy to use. Here's one place where it could use obvious improvement, though. Think about it. Why should showing or hiding file tabs be any different than showing or hiding any other toolbar? And why should docking or undocking file tabs be any different than docking or undocking any other toolbar?

                    PS I don't know about others, but for me, the floating icon is more of a nuisance than anything else. I can see how it would be useful to open up more display space, but the way it gets lost can really lead to a lot of wasted time trying to track it down and figure out what's going on.

                    6,645558
                    Grand MasterGrand Master
                    6,645558

                      Jan 28, 2009#10

                      UEStudio '09 and UltraEdit v15.00 have a new GUI where your thoughts are already realized.

                      18
                      Basic UserBasic User
                      18

                        May 12, 2009#11

                        Along the same lines... using v15.00.
                        I have "lost" my Open File Tabs bar several times now because I have hit the little X thinking I was closing a file. Well, I have found an option that removes the X!

                        Click Advanced - Configuration
                        Under Application Layout - Advanced
                        Put a check beside Disable all Workspace "Close" buttons

                        That removes the X from the Open Files bar.

                        7
                        NewbieNewbie
                        7

                          Jul 22, 2011#12

                          This one bit me again. I lost the SSH / Telnet window by some misfortunate clicking/dragging/double-clicking event. Again, on a laptop in a dual-monitor setup.

                          After much head-scratching, finding this page, and turning off the second monitor (Win-P opens "Projector" controls in Win 7...handy!), I was able to find the rogue window, showing just a few pixels under the Windows start menu.

                          Of possible note, the monitors are different resolution, and in particular the external monitor is taller than the primary monitor, resulting in a huge no-mans-land above the primary display. This is a frequent dumping ground for windows in various applications that feel the need to relocate itself on the desktop. (e.g. centering, resizing, pseudo-fullscreen, etc.) These "helpful" application features usually just annoy me. This time it stung me bad because the SSH window just happened to be small enough to fit entirely in the no man's land (no handles to grab), and old faithful Alt-space (which will usually locate a hidden window and allow you to move it with the cursor keys) didn't work on this "floating pane" window doesn't have the regular windows menu thingee.

                          As a future-proofing step, I right clicked on the title section of the SSH window (and the editor Open Files Tab) and unchecked "Undockable". I thought that meant it couldn't float away, but now that I test it a little, I'm not sure what that does.

                          HTH,
                          -dave

                          6,645558
                          Grand MasterGrand Master
                          6,645558

                            Jul 23, 2011#13

                            What Undockable is for is explained in help of UltraEdit on page Open File Tabs command in last paragraph. This explanation is for all Undockable settings of all dockable views. (Found by using Search of help.)

                            If Undockable is enabled as it is by default, it is possible to click with primary (left) mouse button on the title bar of a docked view, hold the mouse button and move the window of the view either to a different side to get it docked there, or to a free area and let it float there when leaving the mouse button. That's window positioning by drag and drop. If moving the window of a view should not be possible by drag and drop, the setting Undockable should be unchecked.

                            Independent of the state of Undockable it is possible to change a docked window of a view with a double click with primary (left) mouse button on the title bar to a floating window. Such a double click on the title bar of a floating window changes the window back to a docked window.

                            When next time a floating window can't be found, use View - Views/Lists - Recover Floating Windows. That command moves all floating windows partly or completely outside the main window of UltraEdit inside main window of UE.

                            1
                            NewbieNewbie
                            1

                              Re: I lost/undocked the Open Files Tab bar/view

                              Mar 11, 2013#14

                              what a nightmare . . . .
                              inadvertently lost the file tab bar and it floated away . . .
                              please .......

                              6,645558
                              Grand MasterGrand Master
                              6,645558

                                Mar 12, 2013#15

                                Starting with UE v15.00 and UES v9.00 there are now two types of File Tabs - Dockable and Undockable.

                                Only with Dockable file tabs the Open Files title bar is visible and has by default the X symbol to close the open files tab bar. For more information about these two types of file tabs respectively document windows see How to configure the appearance of the open file tabs bar in UE v15.00 and later?

                                As many users accidentally closed the file tabs bar instead of closing the active file, IDM first added a confirmation prompt in UE v15.10 and UES v9.10. So when a user clicks on wrong X the confirmation prompt opens giving the user the chance to cancel closing the open file tabs bar. Unfortunately many users closed the open files bar nevertheless because simply clicking on button OK without reading the message text.

                                At Advanced - Configuration - Application Layout - Advanced there is since UE v14.10 and UES v6.60 the setting Disable all Workspace "Close" buttons which removes the X from the Open Files title bar and also from title bar of all other views. This setting can be used also to avoid accidental close of the open file tabs.

                                Last since UE v17.30 and UES v11.20 there is at Advanced - Configuration - Application Layout - File Tabs - Miscellaneous the setting MDI close button closes active file (not file tabs). With this setting enabled clicking on X in Open Files title bar results in closing the active file instead of the open file tabs.

                                So how to get back the Open File Tabs?

                                First, in menu View is the submenu Views/Lists containing the menu item Open File Tabs. If the icon left this menu item is not checked, the open file tabs bar is currently closed and simply clicking on the menu item opens the open file tabs bar.

                                Now the open file tabs bar can be still not visible because floating outside of visible screen area (multiple monitors) or below a window which is always on top like the Windows task bar. For such situations there is View - Views/Lists - Recover Floating Windows which moves all floating views currently completely or partly outside the UltraEdit main window back into the main window of UltraEdit at nearest position in reference to the floating position outside the main window. Of course this command makes only sense if the UltraEdit main window itself is completely within visible area on a turned on monitor.

                                After using command Recover Floating Windows the floating open file tabs bar is within the UE main window and can be docked again by either simply double clicking on the title bar of this window or using drag and drop to any side of the UE main window (most likely the top side).

                                The Open File Tabs bar could be also configured to auto-hide. In this case there is a tab on the side where the bar is docked with title Open Files and mouse pointer must be moved over this tab to open the bar. Clicking on the pin symbol on right side of the Open Files title bar toggles auto-hide mode.

                                If the Open File Tabs bar cannot be restored by the available menu commands, it is possible to open %APPDATA%\IDMComp\UltraEdit\uedit32.in0 or %APPDATA%\IDMComp\UEStudio\uestudio.in0 with Notepad while UltraEdit is not running and simply delete entire section [Dockbars.002Pane-143]. The visibility of the Open File Tabs bar is remembered in the workspace file under [Dockbars.002BasePane-143].