Painfully slow response when connected via VPN

Painfully slow response when connected via VPN

7
NewbieNewbie
7

    Dec 12, 2007#1

    When I use UltraEdit to edit files on our network over a (Cisco) VPN, the files take 20-30 seconds each to load. Once loaded, the UE goes "not responding" for periods of up to a minute frequently. Sometimes even clicking a menu will take a long time.

    The files are not large (2 to 3K). Notepad opens 'em in "no time". The VPN itself is very fast -- at least judging by file copy times.

    I've tried turning off the option to make a copy, but that is only supposed to help for large files

    The whole experience is so painful, I've taken to using Notepad again when I have to work from home. Strangely, making a local copy and editing from there does not seem to help -- well, they load quicker, but the frequent non-responsiveness and otherwise slow behaviour continues. What could be wrong?

    What settings should I be playing with?

    Regards,
    --Vorpal

    6,606548
    Grand MasterGrand Master
    6,606548

      Dec 12, 2007#2

      Have you enabled Use temporary file for editing (normal operation)?

      Have you disabled File Change Detection?

      Have you disabled Check short names against files already loaded to prevent loading two copies of same file?
      You should play also with the other settings in the dialog File Handling - Advanced.

      Have you open the File Tree View?
      Yes, then close it or at least uncheck setting Show registered file type icons in Explorer view at Application Layout - Advanced  (UE < v14.10) or Application Layout - File Tree View (UE >= v14.10). Depending on your version of UE (v14.10 and later) there are other useful settings at Application Layout - File Tree View to reduce number of directory and file accesses which should be used by users using VPN connections.

      You can also turn off backups or specify a local backup directory instead of the directory of the file (as I have done too). Automatic saves are also not a good idea when working with remote files.

      Note: I have never opened files via VPN. You should simply change your settings to avoid any background file or directory access as much as possible.

      And of course all the configuration files UltraEdit uses (INI, HtmlTidy config file(s), menu and toolbar profile files, keyboard mapping file, template file, ...) should be local files on your computer and not loaded via VPN. Notepad with it's settings (registry) is also running locally.

      52
      NewbieNewbie
      52

        Feb 11, 2008#3

        I have a similar problem. When the VPN is connected and drives are mapped I have no performance issues. I have UE startup performance issues when I 'disconnect' the VPN the drive letters are still mapped, but to nowhere.

        6,606548
        Grand MasterGrand Master
        6,606548

          Feb 11, 2008#4

          schwit wrote:I have UE startup performance issues when I 'disconnect' the VPN the drive letters are still mapped, but to nowhere.
          That is normal behavior if you have enabled to remember files previously open and reload it on next start or if on the Explorer tab of the File Tree View an existing but non accessible drive has the focus. UltraEdit tries to open the files or tries to update the file tree view via the Windows kernel functions and because of the drive mappings still exist but the server is not available the standard TCP/IP timeouts of several seconds are getting active. This is not a performance problem. This is a problem caused by wrong handling VPN connected drives and using the wrong settings.

          Any program would have the same problem. For example if you would open a WORD document on the drive mapped via VPN, close the document, disconnect the VPN and then use the recent file list to re-open the document in MS WORD you will have to wait a "long" time until you get the message that the file is not available. Or you use for a locally stored WORD document a WORD template on a server and the server is not available when you open the document next time. In this case you also have to wait several seconds until you see the document content. Many "not responding" programs are in real "waiting for network timeouts".
          Best regards from an UC/UE/UES for Windows user from Austria

          4
          NewbieNewbie
          4

            Jun 20, 2008#5

            I was having the same problem today, found this thread, made sure all these settings were as suggested and viola. Thanks!

            29
            Basic UserBasic User
            29

              Jun 06, 2011#6

              Nothing is working for me - still 10 seconds to save a file on a file server share via VPN. Local files are fast.

              Have you enabled Use temporary file for editing (normal operation)?
              Yes, as per default.

              Have you disabled File Change Detection?
              Yes

              Have you disabled Check short names against files already loaded to prevent loading two copies of same file?
              Yes

              You should play also with the other settings in the dialog File Handling - Advanced.
              All disabled.

              Have you open the File Tree View?
              No

              You can also turn off backups or specify a local backup directory instead of the directory of the file (as I have done too). Automatic saves are also not a good idea when working with remote files.
              Backups were local, now disabled.

              6,606548
              Grand MasterGrand Master
              6,606548

                Jun 06, 2011#7

                Users of UEStudio should perhaps also uncheck the settings Do not use cache for symbols (for using cache) and Auto re-parse documents when saved (for running parser only on project load or on manual execution) at Advanced - Configuration - IDE - IntelliTips - Parser. I'm not using a VPN connection, but it could be that parsing the file for symbols is not done on temporary file, but on just saved file.

                If above makes no difference, I can only suggest to use free Windows Sysinternals (Microsoft) tool Process Monitor to log all activities on local disk, registry and network during a file save loaded from a share via a VPN tunnel. Look for larger time differences in the log to find probably out where the delay happens and which process is responsible for the delay.

                29
                Basic UserBasic User
                29

                  Jun 06, 2011#8

                  Nope, these changes had no effect. I also assume that, since I am not using a project, no symbols are parsed anyway. Using Process Explorer I did notice something weird. I started UEStudio.exe by opening a file with right-click -> UEStudio. The SW loaded and the IO reads for that process were 312 with 8 writes. Then, the mandatory 10-20 seconds were waited out as the simple text file loaded. At the end, the reads were 1827 and writes 4261! Tried the same with a local file and, apart from the speed (no wait) the reads and writes were approximately the same. So we don't have more I/O, just longer waits.

                  6,606548
                  Grand MasterGrand Master
                  6,606548

                    Jun 07, 2011#9

                    More than 4000 writes is very strange. I used now also Process Explorer as I started UEStudio v11.00.0.1009 and loaded a small C project with 1 file opened (55 KB). Process Explorer recorded more than 4000 I/O reads, but just 37 I/O writes. Loading the project caused exactly 301 I/O reads and only 2 I/O writes. It would be really interesting on which files those 4261 writes occur which could be find out with Process Monitor.

                    29
                    Basic UserBasic User
                    29

                      Jul 01, 2011#10

                      I had posted all the details in a separate thread which was later deleted by forum moderator after I reported the problem to IDM with the recorded data.

                      5
                      NewbieNewbie
                      5

                        Jul 02, 2011#11

                        I've noticed when working with a 200k file, there is about 600Kb of I/O activity per keystroke. Something is up.

                        1

                          May 03, 2012#12

                          The reason of slow response from VPN is optimal MTU. You have to modify the size of MTU, this will lead your VPN fast. Another reason may be browsing the shared folders of remote computer will slow VPN speed. When the client access to VPN, it will take several minutes to open any folder.

                          2
                          NewbieNewbie
                          2

                            May 24, 2012#13

                            I too am having the same slow issues when attempting to open files across my WAN. I've been using UltraEdit for years on my computer network LAN/WAN and I know precisely when this issue started. It started the day my computer was upgraded to Windows 7.

                            I also firmly believe this issue is directly related to the plethora of people complaining of very slow file access in Windows 7 via Windows Explorer when browser folders/files on other servers across a WAN. Example: Why is Windows 7 so slow in copying network files?

                            My own experience is the same; before when I had Windows XP my file browsing across the WAN was fast, and UltraEdit´s ability to open files was fast. We have a fast network. The once I got upgraded to Win7 my file browsing on servers across the WAN took a huge hit in performance and so did UltraEdit´s response in accessing WAN files.

                            Windows Notepad will open the files quickly.

                            I believe the issue can be alleviated by playing with the UltraEdit file settings, as mention previously above (turning off file detect is probably the biggest hit), but I edit files locally and WAN on regular basis and I do not want lose those features on local files.

                            IDM should add an UltraEdit ability to "play nice" and be less network-talkative when dealing with files on remote servers. If such abilities already exist then I would be happy to hear of them. The tricky part would be to identify LAN servers to WAN servers. I can access/edit LAN server files just fine; but when reaching to WAN servers (WAN servers on other side of the country as opposed to LAN servers in our own local building) that's when the hit happens.

                            As I've said, I've been working this scenarios for years and the WAN access took a huge hit when Windows 7 was installed on my computer, and UltraEdit was also adversely affected.

                            Regards,
                            Eric

                            1

                              Nov 29, 2023#14

                              Quite an old thread, but the "Disable File Change Detection" works for me, when editing files over internet (half way around the globe).
                              This tested on Version 25.20.0.166

                              This fixes the painfully slow response whenever UltraEdit loses focus and back again.