Parsing of Ruby files

Parsing of Ruby files


    Aug 01, 2005#1

    I posted this originally in the General section, but I guess classviewer forum is more appropriate for this. Anyhow, I can't get the class viewer to work with ruby files. Here is what I have done so far:

    1. Checked ctags website. Ruby is supported.
    2. Used commad line ctags to parse my file. It found the class and two functions (correct)
    3. Use ues_ctags to parse the file. Same result as above.
    4. When UE tries to parse the file, it displays: Parsing Done: 3 Symbols loaded
    5. Classviewer displays the class name, but it will not expand to view the methods and properties.

    I tried the above on PHP and C# files and everything works like a charm. What gives?

    Btw, if the above file is part of a project. The functions are displayed under Globals/Functions branch. Is this a bug?



    Basic UserBasic User

      Jan 04, 2007#2

      The classviewer does not display ctags data. You will have to send a feature request to IDM to allow the addition of custom languages to the classviewer.