Problem with language bar in Win 7

Problem with language bar in Win 7

11
Basic UserBasic User
11

    3:36 - Apr 22#1

    I wish to report one more bug in UltraEdit v.30 and v.31 x64 under Windows 7 x64: when UltraEdit run, position of language menu is changing from lower right to upper left corner of the screen.
    Normal appearance of language menu:
    normal.jpg (177.45KiB)
    Appearance of language menu when UltraEdit is running:
    ue.jpg (180.66KiB)
    Note that happens after fresh install of UltraEdit, when customized bar with FB2 edit tools is not installed yet.
    If UltraEdit is running, but is minimized, language menu not appear when clicking language icon in system tray.
    In UltraEdit v.29 and lower this problem not persist.

    6,633551
    Grand MasterGrand Master
    6,633551

      6:38 - Apr 22#2

      I suggest first doing following:
      1. Open Control Panel.
      2. Open Region and Language by:
        • If View by:  Category is selected, click below Clock, Language and Region on item Change keyboards or other inputs.
        • If View by:  Large icons or View by:  Small icons is selected, click on Region and Language and select the third tab Keyboards and Languages.
      3. Click on the button Change keyboards…
      4. Select the second tab Language Bar.
      5. Select for Language Bar the option Docked in the taskbar.
      6. Click twice on button OK and close the Control Panel window.
      However, even with language bar docked in the taskbar, it is right that with UltraEdit having the input focus, the context menu of the language bar is opened inside the document window of the opened file in UltraEdit on using UltraEdit for Windows 2023.?.?.? (30.?.?.?) or 2024.?.?.? (31.?.?.?). That is not really wrong because of the currently selected language/keyboard is always changed just for the application which has currently the input focus and not for all applications independent on where the context menu is displayed on screen. But I have never seen before getting the language bar context menu displayed inside the application window of the application with input focus which requires a big mouse movement after clicking on language bar symbol in the Windows taskbar.

      You could report this issue to UltraEdit support by email. No user reading topics here in the user to user forums can change something on code of UltraEdit for Windows.
      Best regards from an UC/UE/UES for Windows user from Austria

      11
      Basic UserBasic User
      11

        1:04 - Apr 23#3

        А big mouse movement after clicking on language bar symbol in the Windows taskbar is tiny problem. The big problem is that the language menu completely disappears when the UltraEdit is running but minimized. Problem persist in v.UltraEdit 30.2.0.27, 30.2.0.41 and in the last release 31.0.0.28. Version 29.1.0.112 work just fine!