"Replace with" history keeps getting cleared (solved)

"Replace with" history keeps getting cleared (solved)


    Jul 26, 2016#1

    I'm using UEStudio '16 (x64) version, although I have noticed this problem for a while now, since the first 64 bit version I think.

    I use Find & Replace quite often and occasionally find that the Replace with history has been cleared. The Find what history still keeps getting longer until I clear it though.

    Clear recent document/project and search/replace histories on exit is unchecked in configuration.

    It doesn't happen every time I exit (I'm not even sure that is when it happens), but it happens quite often and so far I haven't been able to put my finger on when or what makes it happen.

    It isn't a big deal but it is quite annoying, especially when I have constructed a Regular Expression string to reuse. I know I can save them as Favorites but I often only need them until I have finished working on a set of files (and I forget).

    Has anybody else noticed this or does anybody have any suggestions?

    Grand MasterGrand Master

      Jul 27, 2016#2

      That is indeed a very strange issue. The find history is kept but the replace history is sometimes lost. I think, this is caused by a corruption of uestudio.ini where find and replace strings are stored.

      I suggest to close active project and then all files. Then open Advanced - Settings - Toolbars / Menus - Miscellaneous, click on button Clear history, close configuration with Cancel and exit UEStudio with Alt+F4.

      Now open %APPDATA%\IDMComp\UEStudio\uestudio.ini with Notepad while UEStudio is not running. Search with Notepad for [Replace History]. You should not find this section.

      But if you find this section nevertheless in the file, there was for some unknown reason this section twice in uestudio.ini which causes the strange behavior. Remove section [Replace History] with all replace string items with Notepad, save the file (as ANSI file) and exit Notepad.

      Start UEStudio and watch if replace string history is cleared unexpected again in the next days.

      You could also compress the cleared uestudio.ini into a ZIP or RAR archive and upload the archive file as attachment to your next post. Then I could view your uestudio.ini and look for something problematic caused by a file corruption sometime in the past.

      But please note that uestudio.ini contains also confidential data like your account name in some paths, perhaps your FTP account settings or the names of your scripts with full path. Uploading your uestudio.ini as ZIP/RAR file would make those data public.

      Another method to check uestudio.ini is following:
      • Use Backup/Restore Configuration in UEStudio to create a backup of your entire UEStudio configuration for security.
        Alternatively create a backup of your configuration by creating a copy of directory %APPDATA%\IDMComp\UEStudio while UEStudio is not running.
      • While UEStudio is not running move (cut and paste) %APPDATA%\IDMComp\UEStudio\uestudio.ini for example to directory C:\Temp and rename the file in C:\Temp to my_uestudio.ini.
      • Make one more copy of C:\Temp\my_uestudio.ini in C:\Temp with name my_sorted_uestudio.ini
      • Now start UEStudio which creates %APPDATA%\IDMComp\UEStudio\uestudio.ini completely new with the default settings. After closing all document windows exit UEStudio.
      • While UEStudio is not running copy (copy and paste) %APPDATA%\IDMComp\UEStudio\uestudio.ini for example to C:\Temp.
      • Download from Macros for smart sorting INI and REG files the ZIP file specialfilesorts.zip and extract at least the macro file in the ZIP file to C:\Temp.
      • Start UEStudio, load the macro file C:\Temp\SpecialFileSorts.mac, open the files C:\Temp\uestudio.ini and C:\Temp\my_sorted_uestudio.ini, run on those 2 files the macro Sort UE/UES INI and save both files.
      • Run a file comparison with default sorted C:\Temp\uestudio.ini and your sorted C:\Temp\my_sorted_uestudio.ini and look for something suspect in my_sorted_uestudio.ini.
      • In case of you can find something, fix it in C:\Temp\my_sorted_uestudio.ini or in C:\Temp\my_uestudio.ini and save the fixed INI file. Exit UEStudio, delete %APPDATA%\IDMComp\UEStudio\uestudio.ini, copy the fixed INI file with your settings to %APPDATA%\IDMComp\UEStudio and rename the file there back to uestudio.ini.
      When UEStudio is working fine in the next days, delete the backup created in first step respectively create a new backup of your configuration with now working configuration and delete the files in C:\Temp.
      Best regards from an UC/UE/UES for Windows user from Austria


        Jul 27, 2016#3

        Thanks for the reply.

        I tried your first suggestion: cleared history and checked in Notepad - there was no [Replace History] section.
        I tried 'Another method to check uestudio.ini': I couldn't see any differences that looked relevant (that macro looks useful by the way).
        I did notice that my old ini file was named 'uestudio.ini' whereas the new one was 'UEStudio.ini', maybe not relevant in itself but I guess that it shows that it probably came from an older setup. I don't remember now, but it is possible that I actually copied my old ini file after updating to the 64 bit version.

        Anyway, I have kept the new, default ini file that was created and setup UES to my liking again and I will see what happens over the next few days.

        Thanks again for your help.

          Jul 31, 2016#4

          Just to update you:

          I think it is safe to say that everything is working ok now.
          Your original suspicion that it was a corrupted ini file was probably correct.
          I've been doing quite a lot of Search & Replace over the past few days and the Replace history is still getting longer, I'm sure it would have cleared by now.

          Thanks again for your help - and for UES of course.