Settings for sort: "enter no more than 1 characters"

Settings for sort: "enter no more than 1 characters"

1581
Power UserPower User
1581

    May 06, 2022#1

    UE 26.20.0.74

    Since a few week I have the problem that always when I start"special sorting / sort with options" (??) I get the message
    Warning: "enter no more than 1 characters"
    ue_sort_1.png (2.24KiB)

    The reason is that I have a lot of spaces here in this setting:
    ue_sort_2.png (15.33KiB)

    The real problem is:
    It doesn't go away. I replaced it with a single char, I reset the entire dialogue - next time I get the message again. What to do against it?

    Thanks
    UE 26.20.0.74 German / Win 10 x 64 Pro

    6,653559
    Grand MasterGrand Master
    6,653559

      May 06, 2022#2

      Okay, I could reproduce the issue with UltraEdit for Windows v26.20 and can tell you the solution.
      1. Open the file %APPDATA%\IDMComp\UltraEdit\uedit64u.ini with Windows Notepad while no instance of UltraEdit is running.
      2. Search for the line with Sort Delimiter= which has two horizontal tabs after the equal sign which is the problem here as UltraEdit v26.20 is not capable removing these two horizontal tabs even on entering in the dialog window a single character like a comma, run the sort on an empty new file and exit UltraEdit.
      3. Replace the horizontal tab characters by a comma, save the file uedit64u.ini and exit Windows Notepad.
      4. Start UltraEdit, open a new file with Ctrl+N if the active file is not already a new file and open the Advanced Sort/Options dialog window. That should be possible now without getting displayed a message box with the error message: Enter no more than 1 characters.
      5. Uncheck the option Custom delimited sort (German: Individuell abgegrenzte Sortierung) and check instead the option above Tab delimited sort (German: Tabstopptrennzeichen sortieren).
        The translation is not good for these two options in my opinion as native German speaking person. But on the other hand it is really difficult to find a better and short enough German translation for these two options.
      That should fix the problem forever.

      Please don't copy and paste a horizontal tab character via clipboard in future into the edit field of Delimiter (German: Trennzeichen). There would be necessary UltraEdit for Windows v27.00 or an even newer version which works also with a horizontal tab character pasted into the edit field by a user via the clipboard instead of using the option Tab delimited sort.
      Best regards from an UC/UE/UES for Windows user from Austria

      1581
      Power UserPower User
      1581

        May 09, 2022#3

        Thanks Mofi,
        works fine as usual.

        (yes, I suppose that copy&paste was the reason for this problem.)

        Have a fine day!
        UE 26.20.0.74 German / Win 10 x 64 Pro