SFTP - Crypto algorithm could not be negotiate error (How to identify failing cipher?)

SFTP - Crypto algorithm could not be negotiate error (How to identify failing cipher?)


    Aug 03, 2018#1


    I am using UltraEdit for Windows version

    For some Unix-AIX server, whenever trying to connect to SFTP (using Open via FTP) and then clicking connect it gives me this error.

    Whereas I can connect to same server same account with other FTP client (like WinSCP or SecureFX) without any problem!

    If I try to use SSH/Telnet console and click on connect, it just disconnects as soon as possible and provide no error.

    Does anyone know how to identify which cipher the UltraEdit included FTP client is actually sending to Unix SSH server?

    In the FTP account manager I don't have control over the actual "Cipher" UltraEdit is using to establish the connection ... like we do in other FTP clients.

    Is there any LOG file where I could see all the SSH connection messages or is there any way I can configure UltraEdit FTP with actual cipher protocol like aes-256-ctr or other which are actually configured on the Unix server?

    Grand MasterGrand Master

      Aug 04, 2018#2

      UltraEdit v18.10.0.1016 was released June 2012 with wodCertificate.dll, wodFtpDLX.dll (version 3.3.3 build 660) and wodTelnetDLX.ocx from WeOnlyDo Software, see their release notes for wodFtpDLX ActiveX component.

      The Unix-AIX server uses most likely an encryption algorithm not even existing 2012.

      So you have two options:
      1. Upgrade to currently latest version of UltraEdit v25.10.0.50 using currently latest wodCertificate.dll, wodFtpDLX.dll (version 3.5.5 build 755) and wodTelnetDLX.ocx.
      2. Upgrade just those three files from currently latest 32-bit UltraEdit at your own risk as it was done by another user for UltraEdit v16.30, see UltraEdit for Windows v16.xx won't connect to Raspberry Pi with SSH (solved).
      Open Advanced - Configuration - FTP and check option Show FTP log in output window for getting a log written to output window on connecting to server.
      Best regards from an UC/UE/UES for Windows user from Austria

      Basic UserBasic User

        Dec 09, 2021#3

        Just want to say THANK YOU for this even another 3.5 years later... I have a crusty old system that I had v16.30 on and it worked fine until a recent host migration where I needed to connect to a Raspberry PI ... works like a charm but I could not find the files when I installed the latest current 32 bit EXE somewhere - had to grab the MSI installer version and extract it to get at them.

        Anyway it STILL works.
        Download MSI file for latest UltraEdit.
        Extract it somewhere.
        Grab the needed files as Mofi said.
        Back up files on your old version and copy over the updated ones.

        Thank you for saving the day yet again Mofi even though you did it years ago.
        -- The Digital Sorceress