SSH Type Mismatch error when connecting with private key

SSH Type Mismatch error when connecting with private key

5
NewbieNewbie
5

    Apr 20, 2023#1

    Created an SSH account entry with latest UE (2022.2.0.52 64-bit) - specified host, SSH, and added login name, specified public key only and path to the private key that works with PuTTY, etc.

    When I click "Connect" to open the account I get a popup "Type Mismatch" and no further information.I tried both RSA private key and Putty PPK file, same result.

    I know this worked for other hosts at one point in UE but not sure how to resolve or even debug. Is there an error log I could look for messages in?

    6,605547
    Grand MasterGrand Master
    6,605547

      Apr 20, 2023#2

      There can be enabled at Advanced - Settings or Configuration - FTP the configuration setting Show FTP log in output window. There must be next opened the Output Window which has now the tab FTP Log in addition to FTP Transfers.

      I don't know what "Type Mismatch" means.

      I can publish here some information which beta testers of UltraEdit for Windows version 2023.0 received by email a few days ago regarding to FTP fixes in Beta 2:
      • Parsing certain large directories is very slow
      • Issue loading PPK v3 keys
      • Files opened in wrong tab group when using tiled windows mode
      • Extra line added to files opened using ASCII transfer mode
      • "Rename Folder" navigates into folder instead of renaming with "Show Current Directory Only" enabled
      • F5 triggers Capitalize command in active file when focus is in FTP pane
      There was in the email received together with Beta 1:
      • Coming in Beta 2: Telnet/SSH update
      • Coming in Beta 2: FTP/FTPS/SFTP improvements
      You might contact support of UltraEdit, Inc. for that reason as your connection issue is perhaps already known by UltraEdit support.

      I have not reported any FTP/FTPS/SFTP or SSH/Telnet related problem in the last months and know nothing about these issues and their fixes.

      PS: It looks like the end of life support of OpenSSL 1.1.1 and the change to OpenSSL 3.0 or 3.1 released a few weeks ago causes developers of user applications (client side) updating the components for SSL, TLS, SSH, etc. to become again compatible with updated servers requiring encryption. That is just my impression on noticing an increase of connection issues posted by users on several web sites.
      Best regards from an UC/UE/UES for Windows user from Austria

      5
      NewbieNewbie
      5

        Apr 21, 2023#3

        Thanks, I have had other issues with this as well that required conversion of the private key between OpenSSH (where private key starts with --- BEGIN OPENSSH PRIVATE KEY -- and rsa (where private key starts with ---BEGIN RSA PRIVATE KEY--).

        The key file conversion process is not well documented and the only helpful thing I found was mostly in responses to blog posts like

        https://stackoverflow.com/questions/549 ... rivate-key

        I enabled the FTP output window as you said but no entries appear when I get the Type Mismatch error.

        I created OpenSSH and rsa versions of my private key file and exported an openssh version of the putty key file using puttygen. I tried them all in the private key field for the SSH connection and they all had the same Type Mismatch result.

        Looks like I will need to file a support case. Thanks for your help.

          Apr 22, 2023#4

          Wrote UltraEdit tech support and they were great as usual. They acknowledged an issue with this version of UE and had me download an older version (2022.1.0.124) that worked with my keys.