Starting debugger with no or automatically closed console window

Starting debugger with no or automatically closed console window

16
Basic UserBasic User
16

    Aug 21, 2014#1

    Every time when I press Shift+F11 (BuildDebugger) UES starts a command window:

    Title: c:\....uespawn.dat
    Inside black window:
    vx20.exe myprog.exe
    Drücken Sie eine beliebige Taste . . .

    What can I do to close this window automatically?
    Best regards from Austria
    Markus

    6,628551
    Grand MasterGrand Master
    6,628551

      Aug 21, 2014#2

      The message Drücken Sie eine beliebige Taste . . . is perhaps output by command pause in a batch file which is called for build and debug in your compiler configuration.

      Click in menu Build on Advanced Build Options, enable setting Show build commands when executing and run the build with debug.

      Can you see if a batch file is executed?

      Look on it and check if it contains and end command pause.

      But it could be also that indeed the code in uespawn.dat results in execution of pause.

      Do you have unchecked Run tools in HIDE mode in Build - Advanced Build Options?

      This advanced build option is by default checked.
      Best regards from an UC/UE/UES for Windows user from Austria

      16
      Basic UserBasic User
      16

        Aug 21, 2014#3

        This message/window comes when I start the Debugger with Shift+F11.

        Code: Select all

        Shortcut:
        Umschalt+F11             BuildDebugger                Debugger starten
        
        uespawn.dat is a binary file.
        
        Both of this works fine:
        Umschalt+F12             BuildRun                     Anwendung ausführen
        Umschalt+F8              BuildBuild                   Projekt erstellen
        The solution:

        In the config file for this compiler

        C:\Program Files (x86)\IDM Computer Solutions\UEStudio\configs\Alaska XBase++\Application

        which can be opened via menu item Select Compiler in menu Build and by pressing button Edit configuration, there are these settings in section [Start Debugger]:

        ShowWindow = 1
        DisplayConsole = 1

        If you don't need the console, you can set

        DisplayConsole = 0

        If you are using a normal windows debugger (vx20.exe), it should work even with

        ShowWindow = 0
        Best regards from Austria
        Markus