Syntax highlighting not working on renamed files (fixed)

Syntax highlighting not working on renamed files (fixed)

10
Basic UserBasic User
10

    May 13, 2022#1

    With syntax highlighting enabled, if you rename the file and change the file extension to one that is unknown to syntax highlighting, then as expected, the syntax highlighting is removed. However, if you rename the file back to how it was, syntax highlighting is not restored. I've tried this with a few file extensions (css, json, html) and the same happens for them all. Even after closing the file and/or closing UltraEdit and reopening, the highlighting is not restored. Is this a known issue?

    6,653559
    Grand MasterGrand Master
    6,653559

      May 14, 2022#2

      You are the first user reporting this issue in the user to user forums. So it was not a known issue in the forums user community, but it is definitely a reproducible issue with UltraEdit for Windows v2022.0.0.102. Please report this issue by email to UltraEdit support. I will do that also to increase the number of reports to two.

      I could see that the rename of the file to a file extension with no syntax highlighting results in storing on exit of UltraEdit in the file %APPDATA%\IDMComp\UltraEdit\volatile\ue.vod the name of the file with value No highlighting under section [View As Syntax Highlighting] like when a user overrides the automatic syntax highlighting selection with manually selecting a syntax highlighting. The selection of No highlighting done by UltraEdit and not by the user is kept on renaming the file once again with changing the file extension back.

      The solution is either manually selecting the correct syntax highlighting language for the file or closing the file, opening Advanced - Settings or Configuration - Toolbars / menus - Miscellaneous, clicking on button Clear history to clear all histories except those of currently opened files, closing the configuration window and reopening the file.

      This issue exists since UltraEdit for Windows v27.10 and UEStudio v20.10. Former versions of UltraEdit and UEStudio do not have this issue.
      Best regards from an UC/UE/UES for Windows user from Austria

      10
      Basic UserBasic User
      10

        Jan 03, 2023#3

        For me, the issue is resolved. Version 2022.1.0.124 on Windows.

        6,653559
        Grand MasterGrand Master
        6,653559

          Jan 04, 2023#4

          Yes, this syntax highlighting issue is fixed according to my tests with UltraEdit for Windows v2022.1.0.90 and UEStudio v2022.1.0.90.
          Best regards from an UC/UE/UES for Windows user from Austria