UE Configuration for .as file association

UE Configuration for .as file association

25
Basic UserBasic User
25

    Feb 13, 2009#1

    I'm trying add a file type association for .as files; however, I can't manually add the ".as" extension, and this option is not available from the Advanced > Configuration > File Associations File types/extensions list. Is there another place I can add this extension? Thanks for the help!

    UE v. 14.20.1.1008

    344
    MasterMaster
    344

      Feb 14, 2009#2

      Hi, I think you are just overlooking one thing: The given extensions are just suggestions, equal to
      Word: Text size ... 10,12, 16, ...
      Just OVERTYPE it by 11 or in this case .as, and you are set.
      I did so, closed UE, renamed test.txt to test.as, doubleclicked the file, and UE opened the file.

      rds Bego
      Normally using all newest english version incl. each hotfix. Win 10 64 bit

      6,632551
      Grand MasterGrand Master
      6,632551

        Feb 14, 2009#3

        In the drop down list File Types/Extensions type .as and in the edit field Description enter a short text explaining what files with extension AS are. As long as you don't enter something in the description field, the button Add is disabled.

        Of course you need administrative privileges to register a file association. You can't do that with a restricted account. That's a security policy of Microsoft (by way of exception a good one).
        Best regards from an UC/UE/UES for Windows user from Austria

        25
        Basic UserBasic User
        25

          Feb 17, 2009#4

          Hi, Mofi and Bego...

          Thanks for the reply. For some reason, UE keeps auto-"correcting" to .asm. When I type ".as" in the drop-down, then click in the Description field, the ".as" is changed to ".asm". I tried backspacing the "m" out and clicking Add, but the extension still changes to .asm. I am an administrator on this account. I've also tried deleting the .asm and clicking OK, then trying to add the .as again. Same results. I'm stymied: I've done this before in previous versions of UE. :? Thanks, again for the help.

          344
          MasterMaster
          344

            Feb 17, 2009#5

            Hm, I tried around, created a new .as and it stayed ".as", although I have got a ".asm" already.
            Could not reproduce your behaviour in any way, though. Sorry.
            UE 14.20.1.1008 on Vista 64
            Normally using all newest english version incl. each hotfix. Win 10 64 bit

            25
            Basic UserBasic User
            25

              Feb 17, 2009#6

              Thanks for giving it a try, Bego. It tried with both the ".asm" entry existent and non-existent in the list. I'll see if anyone else onsite can reproduce the problem.

              6,632551
              Grand MasterGrand Master
              6,632551

                Feb 19, 2009#7

                I was not able to reproduce your problem although I have also .asm already associated. I recorded what UltraEdit changes in the registry and exported it as registry file. You have to adapt the red text before you can import that into your registry. When you open the file associations configuration dialog after importing below into the registry you will see the file association also in UltraEdit.

                Note: In my registry there was no existing association for .as. UltraEdit normally saves the existing file association and restores it on deletion. This registry file does not do that.

                REGEDIT4

                [HKEY_CLASSES_ROOT\.as]
                @="UltraEdit.as"

                [HKEY_CLASSES_ROOT\UltraEdit.as]
                @="Description"

                [HKEY_CLASSES_ROOT\UltraEdit.as\shell]

                [HKEY_CLASSES_ROOT\UltraEdit.as\shell\open]

                [HKEY_CLASSES_ROOT\UltraEdit.as\shell\open\command]
                @="\"C:\\Program Files\\IDM Computer Solutions\\UltraEdit\\uedit32.exe\" \"%1\""

                [HKEY_CLASSES_ROOT\UltraEdit.as\shell\print]

                [HKEY_CLASSES_ROOT\UltraEdit.as\shell\print\command]
                @="\"C:\\Program Files\\IDM Computer Solutions\\UltraEdit\\uedit32.exe\" /p \"%1\""
                Best regards from an UC/UE/UES for Windows user from Austria

                25
                Basic UserBasic User
                25

                  Mar 02, 2009#8

                  Thanks, Mofi! I appreciate the extra effort on your part. Totally swamped with other issues right now, but I'll certainly give that a try.