UEStudio not registering 32 bit shell extension on Windows x64 (solved)

UEStudio not registering 32 bit shell extension on Windows x64 (solved)


    May 21, 2012#1

    Just thought I should point this out (may affect UE and other apps, not sure): UEStudio not fully 64 bit compatible after install.

    UEStudio failed to include anything in the HKEY_CLASSES_ROOT\Wow6432Node\CLSID node of the registry.
    Thus no 32 bit application using Explorer/IE functions would have UEStudio displayed in their right-click.
    The most common place to see it is Common Dialogs.

    Install UEStudio on Windows 64 bit version (XP, Vista, 7).
    Start Internet Explorer (default should be normal/32 bit as Microsoft does not recommend and does not default to IE64) or Mozilla Firefox or any other application that is still 32 bit (a lot of development and graphics apps). Or a 32 bit Windows Explorer replacement such as Cubic Explorer, or just any other 32 bit application that calls standard Windows Dialogs or File Browse routines.
    Select a file.
    In the File Open dialog or file browser, browse to a file, right click and notice there is NO UEStudio OPTION!

    The fix for UEStudio was to add the following registry entry (assumes install path is default):

    Code: Select all

    Windows Registry Editor Version 5.00
    @="C:\\Program Files (x86)\\IDM Computer Solutions\\UEStudio\\uesctmn.dll"
    As you can see what was done there was to add a call under the Wow6432Node to the 32 bit DLL.
    Now UEStudio options work and show in CE and other 32 bit applications which make calls through Explorer/IE and any other application that makes calls to Windows native 32 bit code while running Windows x64.
    As such now Windows x64 would be fully supported on both the 32 bit and 64 bit code paths under Windows x64 (XP 64 bit, Vista 64 bit, 7 64 bit).


      May 22, 2012#2

      Have you reported this to IDM Support so that this can be fixed in an upcoming release?

      Grand MasterGrand Master

        May 22, 2012#3

        You should also post which version of UEStudio you think is not fully compatible with Windows x64 because not registering 32 bit shell extension on Windows x64.

        UEStudio v12.00 and later install and register both shell extensions by default - the 64 bit ues64ctmn.dll for 64 bit applications and additionally the 32 bit uesctmn.dll for 32 bit applications. Versions of UEStudio prior v12.00 install and register just 64 bit shell extension ues64ctmn.dll.

        The shell extension registration can be changed at any time in UEStudio via Advanced - Configuration - File Associations with setting Integrate with explorer as. This registration is by default not done anymore in HKCR respectively HKLM\Software\Classes as this requires administrator privileges which most users especially on Windows 7 and Vista do not have. The shell extensions are registered now under HKCU\Software\Classes which does not require administrator privileges and works also with UAC enabled. And every user on a computer with multiple user accounts can now decide to register and use the shell extension or not.

        Users of UEStudio on Windows x64 upgrading from prior v12.00 should once uncheck Integrate with Explorer as and click on button Apply and then check again Integrate with Explorer as and click on button Apply and then Cancel to make sure that both shell extensions are registered now.


          Apr 17, 2013#4

          I know this topic is old, but I have something to add that may be of value to future readers of this thread.

          This past week I upgraded my computer to Windows 7 Ultimate 64-bit.
          I am using UEStudio

          Both the 64 bit and 32 bit shell extensions are working as expected. Therefore, I can confirm what Mofi wrote about UES versions 12+ do register them both properly.

          I wanted to confirm this since Mofi does not have Windows 7 installed.