UltraCompare Color Scheme

UltraCompare Color Scheme

1

    Jun 18, 2014#1

    I just installed new version 14.0.0.1003 on my Windows 7 Home Premium (x64) system. I do not like the dark theme that is the default. I find a lot of the screen text hard to read. I want a light background. I've searched the forum(s) and did find something that said this could be changed under the "Color and Font branch under Configuration" however that was from 2011 and there is no such choice under Options/Configuration or any of the listings there. I also found some discussions of a tool for themes but that referred to UltraEdit. How can I change this theme? As it stands now UC is almost unusable for me. :(

    6,624550
    Grand MasterGrand Master
    6,624550

      Jun 18, 2014#2

      You should take a look on the New feature tour for UltraCompare for Windows.

      Light themes are Modern Light and Classic selectable in menu View - Themes. A customization of the special theme Classic requires the selection of Custom on tab Application for the Application style.

      The Manage Themes dialog lets the user select a theme and preview the look of UltraCompare with the selected theme before applying it permanently. In this dialog also all colors and some fonts can be set if the user wants to create his own UltraCompare theme and also preview them before saving it into the theme file.

      As I'm still a fan of Windows 95 desktop theme and have configured my Windows 7 and Windows XP computers to look like Windows 95 as much as possible (Windows Classic theme with no visual effects enabled, color fading in title bars disabled, clear type disabled, mnemonic keys always underlined, no shadows), the UC/UE/UES Classic theme with Windows Classic is the application style I'm using.
      Best regards from an UC/UE/UES for Windows user from Austria

      2

        Sep 24, 2014#3

        I'm running UltraEdit Professional Version 21.20.0.1014
        and UltraCompare Professional Version 14.0.0.1011

        Just installed UltraCompare 14 and the colour scheme had changed, to grey text on a grey background (which I find very difficult to read).

        How do I change themes in UltraCompare 14 ?

        I found some stuff explaining about themes, and the new features in UltraCompare 14, which said to find themes on the view menu, but my view menu in UltraCompare has the following in it ...

        All
        Just Differences
        Just Matching
        -----------
        Center On Difference
        Show Output Window
        Show Explorer & Sessions
        -----------
        Show Line Numbers
        Show Active Line Window
        Show Tabs/Spaces
        Show Previous File (greyed out)
        Toggle Word-Wrap
        Relational Lines Mode
        -----------
        Browser View
        -----------
        Synchronize
        Refresh
        Go (greyed out)

        I cannot find anything in the menus about themes.

        6,624550
        Grand MasterGrand Master
        6,624550

          Sep 24, 2014#4

          Right click on the main menu and left click on Manage Menu Configurations. Click on button Reset to update your main menu to newest version.

          It looks like the main menu was not updated on first start after installing UC v14 for some unkown reason. You can do that also via Advanced - Options - Toolbars / Menus - Management.
          Best regards from an UC/UE/UES for Windows user from Austria

          2

            Sep 26, 2014#5

            Thanks, Mofi.

            I had to try several things, but eventually got the Themes menu available under the View Menu.
            In case anyone else needs to know, I had to do this (or at least this is what worked for me):
            1. From the Options Menu, select Configuration.
            2. In the tree that appears, open "Toolbars / Menus" and click on Management.
            3. To the right of the tree, click Manage Toolbars, then Reset All, then Close.
            4. To the right of the tree, click Manage Menus, then Reset All, then Close.
            5. Click OK (to close configuration window).
            I found the first item on the View menu is now Themes, however when I selected a different theme, it crashed and closed UltraCompare.
            When I started UltraCompare again, it had returned to the original colors and everything seems OK.

            49
            Basic UserBasic User
            49

              Aug 09, 2017#6

              I am using UC Professional 15.20.0.6. Every time I start UC, I get the message "The Menu file is out-of-date. UltraCompare will update it now". I click OK and main window displays. It doesn't update anything. Same message every time I start UC.

              I have tried everything in this thread but nothing has worked. I can't see the "Themes" option in the View Menu. Even reinstalling didn't help.

              Has anyone any ideas?

              Thanks in advance.
              Subhash.

              6,624550
              Grand MasterGrand Master
              6,624550

                Aug 09, 2017#7

                Subhash, open the directory %APPDATA%\IDMComp\UltraCompare while UltraCompare is not running and delete the two files UCCmds32.cmf and UCMNCmdsW32.mcf. Then start UltraCompare and it should create the toolbar configuration file and the menu configuration file without showing a message.
                Best regards from an UC/UE/UES for Windows user from Austria

                49
                Basic UserBasic User
                49

                  Aug 09, 2017#8

                  Hi Mofi. Thanks for the quick reply.

                  I did what you suggested but it didn't work. Here is what I did.
                  1. Closed UC.
                  2. Opened the folder %APPDATA%\IDMComp\UltraCompare and deleted the two files, UCCmds32.cmf and UCMNCmdsW32.mcf.
                  3. Started UC again. Got the message again. Clicked OK and then checked the menu and still "Themes" option was not there.
                  4. Then did everything else in this thread i.e. reset all menus/ toolbars but no good.
                  5. Closed UC again.
                  6. Then I found another folder C:\UltraCompare Portable\Data which also had the two files with current timestamp.
                  7. Deleted these two files as well.
                  8. Restarted UC and got the message again. Clicked OK. Menu files appeared again in the folder C:\UltraCompare Portable\Data but not in %APPDATA%\IDMComp\UltraCompare.
                  9. Menu item "Themes" still didn't show up.

                  6,624550
                  Grand MasterGrand Master
                  6,624550

                    Aug 10, 2017#9

                    You forgot to mention that you are using the portable version of UC Professional 15.20.0.6 which is important for this problem because always showing this message on start of UCP v15.20.0.6 was a bug in portable version only. There is no workaround for this bug. You have to update to a newer version of UltraCompare Portable.

                    Please contact IDM support regarding this problem and ask for a newer version with this bug fixed usable with the bought license. Or upgrade to latest version of UC.
                    Best regards from an UC/UE/UES for Windows user from Austria

                    49
                    Basic UserBasic User
                    49

                      Aug 10, 2017#10

                      Hi Mofi. Sorry for the oversight. I should have mentioned before that I am using portable version but I didn't realize until I checked the folder name from the desktop shortcut after you replied to my post. UC itself doesn't display anywhere that it is portable. Before posting my question I checked the version of UC. On the title bar of the main screen it displays Text Compare - UltraCompare Professional and under Help - About it displays UltraCompare Professional. After your reply, I looked at the folders and that is when I found out that it is portable version. The folder name is UltraCompare Portable.

                      Once again sorry and thanks for your help. I will contact IDM and upgrade to a newer version.

                      Subhash.

                      PS: On searching the forums, I didn't run into any thread that mentioned that it is a known problem with UC Portable. Just wondering.