7

    Sep 11, 2017#46

    Turns out there is a wrinkle I discovered (on Windows): When I "left click" on uedit64.exe --> Properties --> Compatibility --> check box "Override high DPI scaling behavior. Scaling performed by:" then select "System" in the box below the load time is much faster, in fact almost instantaneous.

    (And another thing: My scaling is under 250%.)

    25
    Basic UserBasic User
    25

      Oct 08, 2017#47

      These recent posts are discussing Windows 8 or later? Any suggestion for Windows 7? (Running 163% scaling.)

      2
      NewbieNewbie
      2

        Oct 19, 2017#48

        Well it's been almost 18 months since I posted about my issues with slow startup times, but I am happy to say that today I received an email from UE support with a new version to try, and at least on my machine, it seems to perform a lot better. I'd be interested to hear if anyone else has positive results with the latest hotfix release.

        6,606547
        Grand MasterGrand Master
        6,606547

          Oct 26, 2017#49

          IDM released UltraEdit for Windows v24.20.0.44 and UEStudio v17.20.0.15 which have as main improvement a greatly improved startup performance for systems with UHD displays or high font scaling.
          Best regards from an UC/UE/UES for Windows user from Austria

          61
          NewbieNewbie
          61

            Oct 28, 2017#50

            Yes, UltraEdit 24.20.0.44 starts faster (3.5 s). But overriding high DPI scaling behavior with "System (Enhanced)", as mentioned above, is better (1.5 s).

            1
            NewbieNewbie
            1

              Dec 05, 2017#51

              My notes on slowness:

              Hardware = Dell XPS 8900, Intel i7-6700 CPU @ 3.4ghz, 16GB memory

              Git integration was a huge slow-down for me in my projects. Eventually, I had to de-integrate completely and write some powershell scripts to do my pushes.. The repositories had been relatively small, think hundreds of files rather than thousands. The total number of Gits was only a handful (5-6).

              Sometimes it would take several minutes to start UEStudio and at times the whole system would freeze when UE ate up all CPU. Often switching from one tab to another (switch files) caused the system to hang for 10-15 seconds which drove me nuts! Usually, I had about ten programs opened at once. This was infuriating...

              I turned off Virus scanning for all of the locations where UE resided and cached files. This did not help. Read some posts about using startup.log to track down issues. To some extent this was helpful. It did show large times for certain line items, but nothing I did until de-Git-ing all of my project folders seemed to help.

              The only slowness I see now that is unexpected is when I click back into UEStudio when I am in some other application window. It is only a second or two.

              Jhafer.

              7
              NewbieNewbie
              7

                Jan 19, 2018#52

                FlowerStone wrote:Turns out there is a wrinkle I discovered (on Windows): When I "left click" on uedit64.exe --> Properties --> Compatibility --> check box "Override high DPI scaling behavior. Scaling performed by:" then select "System" in the box below the load time is much faster, in fact almost instantaneous.
                This reduced my startup time from 60 s to 30 s.  Better, but still terrible. And the rendering is fuzzier.
                Running 24.10.0.35 x64 on Windows 10. Scaling 125% (Recommended)

                6,606547
                Grand MasterGrand Master
                6,606547

                  Jan 19, 2018#53

                  leotohill, 60 s or 30 s startup time is definitely terrible. There must be really something wrong in your configuration causing this extremely long startup time. I'm using UltraEdit more than 20 years from Windows 95 to Windows 7 on various PCs and the startup time was never longer than 2 seconds on any machine.

                  I suggest first to upgrade to currently latest UE v24.20.0.51 if your purchased license makes that possible. You can see that by clicking on Check for updates (top right menu Support, menu item About, button Check for updates on using ribbon mode).

                  I suggest following to find out if a configuration setting in UltraEdit or a history entry in case of re-opening files on startup is enabled is responsible for the long startup time.
                  1. Exit all running instances of UltraEdit.
                  2. Copy into address bar of Windows Explorer %APPDATA%\IDMComp and hit key RETURN to open this by default hidden directory.
                  3. Rename directory UltraEdit to UltraEditBackup.
                  4. Start UltraEdit which creates the directory UltraEdit as well as all configuration files with default settings.
                  5. Uncheck the check box option to shell welcome screen and close the welcome screen.
                  6. Open Advanced - Settings or Configuration - Editor - Advanced and verify that Load/restore printer settings is not checked.
                  7. Navigate in configuration to Application layout - Miscellaneous and uncheck Automatically check for updates.
                  8. On using File View by default the display of it can be significantly improved especially on an anti-virus application running in background with unchecking Show registered file type icons in Explorer view and Scan for empty folders in Explorer view and Show volume info for floppy drive(s) in configuration at Application layout - File tree view.
                  9. Close the configuration with button OK and exit UltraEdit.
                  Start UltraEdit and measure the startup time.

                  Is it much faster now?

                  Yes, then we can further investigate what causes the long startup time by comparing the configuration as stored in directory UltraEdit with those in UltraEditBackup.

                  No, then change temporarily the scaling to 100% and let us know the screen resolution of your display.

                  Does UltraEdit start with 100% scaling much faster?

                  No, there is most likely an application running in background which slows down UltraEdit startup dramatically. We need to investigate that by looking on file startup.log and most likely using also Process Monitor as explained in other posts of this topic to find out why UltraEdit needs even with default configuration with some settings already set for better speed so long to start.

                  You can restore your configuration after all those tests by exiting UltraEdit, renaming in Windows Explorer directory UltraEdit to UltraEditDefault or deleting this directory and renaming UltraEditBackup back to UltraEdit.
                  Best regards from an UC/UE/UES for Windows user from Austria

                  7
                  NewbieNewbie
                  7

                    Jan 19, 2018#54

                    Thanks for the lengthy reply. I too have used UE for many years, so I recognize that my problem is not common. But on the other hand, others have reported the same.

                    This is basically a new UE install on a new machine. It's the same model as my old computer, where it worked well. (Old computer drive crashed.)

                    I've tried everything you mentioned - no improvement.

                    I've captured a Process Monitor log and the startup log and I emailed them to support last night. Haven't heard back from them yet.

                    (Maybe UE is mad at me because I had a brief affair with vim. But she was high-maintenance and hard to work with. I'm sorry and I'm back.)

                    Update: UE support responded that the Win10 creators update introduced this problem and that UE 24.20.0.51 fixes it. True, I've now downloaded the new version and UE now starts in 5 to 10s. I do think that this fix should be available for free, since the problem pretty much makes UE unusable. (The performance problem extends past startup time.)

                    6,606547
                    Grand MasterGrand Master
                    6,606547

                      Jan 20, 2018#55

                      Thanks for posting what IDM support replied. I could find more details about this issue with this information.

                      The problem is not really caused by code of UltraEdit. It is a modification Microsoft made and many, really many applications including famous once like Adobe Photoshop or Tortoise Git are affected by this change. The developers of UltraEdit just worked around this issue according to a recommendation Microsoft published for developers. In my opinion Microsoft should quickly fix this issue and release an appropriate update for Windows 10 1709 Fall Creators.

                      Every application using the system function GetPixel suffers on a dramatic slow down on Windows 10 1709 Fall Creators, especially those using ribbon interface of Microsoft's GDI+ library as also used by UltraEdit since version 23.00. Is it forbidden to use a Windows system function supported since Windows 2000 which just returns the RGB values of a pixel on screen? Yes, it is since Windows 10 1709 Fall Creators Update.

                      Well, there exists a method to get all applications being affected as fast as before update to Windows 10 1709 Fall Creators by disabling a special exploit protection in Windows Defender. For details read Fall Creators Update poor performance/lagginess FIX. See also MSDN article about Control Flow Guard if you are really interested in this issue.

                      I don't use myself any PC running Windows 10. So I can't test if following the instructions posted in referenced forum topic really solves the problem for users of UltraEdit prior v24.20.0.51 being affected by this Microsoft "enhancement".

                      PS: The best operating system in the last 25 years was and still is: Windows XP. It is really a pity that it can't be used anymore on modern hardware as no drivers are available anymore for Windows XP for new hardware and more and more software is not running anymore on Windows XP. Modern PCs from 2018 are more than 20 times faster than machines from 2008. But Windows 7/8/10 is on those PCs not 20 times faster than Windows XP on PCs from 2008, at least for my work with PCs. (I'm not talking about games or video/audio/data compression applications.)
                      Best regards from an UC/UE/UES for Windows user from Austria

                      7
                      NewbieNewbie
                      7

                        Jan 21, 2018#56

                        This thread says that MS will push a fix out Jan 30. Readers who don't want to purchase an UltraEdit upgrade might want to wait for that.

                        You remind me of my friend Andrew who says that this toaster is the best one every made. He may be right.

                        1
                        NewbieNewbie
                        1

                          Feb 22, 2018#57

                          leotohill wrote: This thread says that MS will push a fix out Jan 30. Readers who don't want to purchase an UltraEdit upgrade might want to wait for that.

                          You remind me of my friend Andrew who says that this toaster is the best one every made. He may be right.
                          I have the slowness symptoms said in this thread.
                          This update works and removes the slowness completely.
                          This has been harassing me for months.

                          I fall back on all the suggested tuning in this thread, but I keep the Control Flow setting off.
                          The software still starts and runs very smoothly.
                          Thank everyone and curse MSft.

                          6,606547
                          Grand MasterGrand Master
                          6,606547

                            Feb 22, 2018#58

                            Microsoft released KB4058258 January 31, 2018 for all users of Windows 10 Fall Creators.

                            But I updated also Office 2010 using Windows Update yesterday and found it interesting to read on page for KB4011187 released February 6, 2018:
                            Microsoft wrote:This update fixes an issue in which opening files in PowerPoint 2010 isn't as fast as it was before you installed Windows 10 Fall Creators Update.
                            I am really happy not using Windows Spy, sorry, Windows 10 on any of my computers. The users of Windows 10 Fall Creators must have really a high-end computer to compensate the performance loss caused by this version of Windows if a compensation by hardware is possible at all.
                            Best regards from an UC/UE/UES for Windows user from Austria

                            Read more posts (-2 remaining)