Unable to select multiple lines of text off-screen (solved)

Unable to select multiple lines of text off-screen (solved)

4
NewbieNewbie
4

    Jul 24, 2017#1

    I have a 46,000 line text file that I'm trying to either cut out about 1,000 lines in the middle of the file or delete the files before and after the 1,000 lines.

    I'm not really sure how to explain this so I took a screen cap and made an animated GIF with 30.5 MB, link here: http://i.imgur.com/VxRtH9v.gifv

    Basically I need to select large portions of my text file and delete it but every time I try to select text and use the scrollbar the program is not keeping everything selected.

    This is the first text editor I've used that can't seem to handle selecting large amounts of text... What is going on?

    I'm using UltraEdit v24.10.0.24

    6,633551
    Grand MasterGrand Master
    6,633551

      Jul 24, 2017#2

      I'm not sure what you have tried (and I have not looked on the animated GIF), but selecting a block with mouse works as in all other applications.

      First, set caret (blinking text cursor) at the position where selection should start, for example line 1000 column 1.

      Then use the vertical scroll bar and scroll down to end position of the selection not yet existing.

      Hold the left or right Shift key on keyboard and left click once (and really only once) into the file where the selection should end, for example line 15983 column 37.

      That's it.

      A double click with left mouse button selects a word or the space between two words.

      A triple click selects the entire line except this feature is disabled in configuration.

      Depending on used settings there is a very thin or a little bit wider area on left side between document window border and first column of the line on which a single click in this area selects the entire line. The mouse pointer changes from a text cursor (looking like an upper case I in Times New Roman) to an arrow pointing from left to right when the cursor (mouse pointer) is positioned over this thin area on left side of the lines.

      Another method to select a block is using Ctrl+G to open the Go To dialog, enter line number for begin of selection and click on button Goto. Then open the dialog once again with Ctrl+G, enter line number for end of selection, press and hold left or right Shift key on keyboard and click on button Goto. The caret is moved to new position and additionally everything from previous position is selected in file.
      Best regards from an UC/UE/UES for Windows user from Austria

      4
      NewbieNewbie
      4

        Jul 24, 2017#3

        Thanks for the reply.

        I am putting my cursor (mouse left click) at the beginning of line that I want to start at. Then I scroll down, using the scroll bar, to where I want the end of the selection to be, I hold the Shift key and then left click with my mouse again at the end of the line I want the selection to end at. Like any other program.

        The preview scroll bar on the right shows every line is selected properly, but when when I hit the delete key (or Ctrl-X to cut) less than half of what I had highlighted is actually removed from the document, even so far as to cut off somewhere in the middle of a line of text.

        I know this sounds nuts, but the program is just not deleting or cutting everything that I selected. It just randomly decides to only delete (or cut) less than half of what I had actually selected.

        6,633551
        Grand MasterGrand Master
        6,633551

          Jul 25, 2017#4

          First, I suggest to update to v24.10.0.32 which is the currently latest available version.

          Second, what you call "preview scroll bar" is the document map as it can be seen by clicking with secondary mouse button into this view which opens the context menu of this view and containing as last item Close document map.

          Third, please don't use the words highlighting or highlighted when you mean selection or selected. Highlighted text in UltraEdit is something different than selected text. It is even possible to have text highlighted within a selected text.

          I have created quickly a file with more than 1.000.000 lines having more than 100.000.000 bytes and selected as described by me a block in the middle with more than half of the file size and deleted/cut this block. It worked well. So I could not reproduce the problem.

          Therefore I would most likely need your file, your UltraEdit configuration (files in application data directory of UltraEdit, i.e. %APPDATA%\IDMComp\UltraEdit) and exact step by step instructions on how to reproduce this issue to be able to verify that problem at all. Of course instead of packing the files into a ZIP or RAR archive and uploading it somewhere with the step by step instructions for verification by another user of UltraEdit like me, you can report this issue also to IDM support by email privately.
          Best regards from an UC/UE/UES for Windows user from Austria

          4
          NewbieNewbie
          4

            Jul 25, 2017#5

            I have just checked for updates and UltraEdit says there aren't any.

            I ran some more tests with other files and found that it appears that I'm hitting some sort of selection buffer limit. The status bar indicates: "Sel: 49998/820 (B/Lns)"

            Every single time I select a large amount of text and my selection gets truncated those numbers are always the same in the status bar. It seems that I'm hitting some sort of buffer limit with the selection that prevents me from going over 49998 bytes.

              Jul 25, 2017#6

              I updated to 24.10.0.32 and now it's working properly, I'm not hitting that 49998 byte limit anymore.

              Thanks!

              2

                Jun 21, 2019#7

                I just purchased UltraEdit 64 bit (26.00.0.74) for Windows 10 (in May 2019)  and I am encountering the same issue.

                I have a large text file containing 371K lines of a SQL backup. I am attempting to delete thousands of lines. I select the line I want to start the delete and then holding the Shift key I scroll down to the line I want to finish the delete and then press the Delete key (and I have tried using the Delete Lines command). The behaviour is that UltraEdit simply unselects the lines and deletes nothing.
                 
                Using this method I can delete hundreds of lines but not thousands of lines. I am vague on the exact number since that would be hard to do.
                 
                Any suggestions would be appreciated.

                6,633551
                Grand MasterGrand Master
                6,633551

                  Jun 21, 2019#8

                  What you are doing wrong is selecting while scrolling downwards. This is not the preferred method to select a large block of text in a text editor or in a word processing application or a large list of files in a file manager on Windows. The preferred Windows method to make a large text selection is clicking (at beginning of) first line to select, then scroll down with vertical scroll bar to last line without holding any key, and press and hold now key Shift on clicking on this last line to select to make the selection from first line to select to last line to select.

                  By the way: Did you report the issue with already selected text partly lost on expanding selection because of holding key Shift permanently during scrolling downwards on crossing currently loaded file block by email to IDM support? It has no effect on future versions of UltraEdit to report an issue in user to user forum. The issue must be reported by email to IDM support.
                  Best regards from an UC/UE/UES for Windows user from Austria

                  2

                    Jun 21, 2019#9

                    Thank you for your suggestion. I did as you suggested and it still did not work.
                     
                    As for reporting it: the usual practice is to see if it is in fact a bug. These things are usually user error but if I get no help on here I will have to report it OR use another editor. Atom has no problem, BTW.

                    6,633551
                    Grand MasterGrand Master
                    6,633551

                      Jun 24, 2019#10

                      spifferlasting, do you have a step by step instruction for reproducing this issue?

                      I tried to reproduce a large selection issue with following steps without success. The large selection was done by 32 bit UltraEdit v26.10.0.38 on Windows 7 x64 with Windows Classic desktop theme always as expected using default settings of UltraEdit with document map not displayed as I never use it.

                      Creation of a large file with more than one million lines:
                      1. I copied ANSI (Windows-1252) encoded file changes.txt with DOS line endings in program files directory of UltraEdit to a temporary directory of my choice like C:\Temp.
                      2. I started UltraEdit and opened the copy of file changes.txt in temporary directory of my choice, i.e. I opened the file C:\Temp\changes.txt.
                      3. I pressed Ctrl+END to set caret to end of file, pressed RETURN to insert a line termination at end of file, and deleted the automatically inserted leading spaces with Shift+HOME and DEL.
                      4. I pressed Ctrl+A to select everything and Ctrl+C to copy selection to clipboard.
                      5. I pressed Ctrl+END to move caret to end of file and next Ctrl+V several times until line number is greater than 100000 (one hundred thousand - 100406 in my case with changes.txt installed with UE v26.10.0.38).
                      6. I pressed Ctrl+A to select everything in file once again and Ctrl+C to copy much larger block to clipboard.
                      7. I pressed Ctrl+END to move caret to end of file and next pressed slowly Ctrl+V several times until line number is greater than 1000000 (one million - 1004051 in my case).
                      8. I pressed Ctrl+HOME to move caret to top of file, pressed Alt+C to enable column editing, clicked on ribbon tab Edit on item Insert number, clicked on button OK to insert number with defaults (start with 1 and increment with 1 with leading zeros and in decimal), and after the numbers were inserted, pressed once again Alt+C to disable column mode. The line numbers inserted at beginning of each line are for better verification if large selection is made correct in the test cases below.
                      9. I pressed Ctrl+S to save the file to avoid to do the steps above once again. The file had 60.276.110 bytes now.
                      First test case was making a large selection with holding Shift on clicking with primary (left) mouse button on end position of the selection to create.
                      1. I pressed Ctrl+G to open Go To dialog, entered 100000 (one hundred thousand) and pressed RETURN to go to line 100000 column 1.
                      2. I scrolled with vertical scroll bar to downwards until I could see the lines around line 800000.
                      3. I pressed and hold left Shift and clicked once with primary (left) mouse button at beginning of line 800000. UltraEdit had do create a selection from line 100000 column 1 to line 800000 column 1.
                      4. I pressed Ctrl+C to copy the 700000 lines to clipboard.
                      5. I pressed Ctrl+N and Ctrl+V to paste the very large block into a new file.
                      6. I verified with looking on the line numbers displayed by UltraEdit at end of new file as well as on line number at beginning of last line line and after Ctrl+HOME also of first line in new file if everything was correct and as expected which was the case.
                      7. I pressed Ctrl+Z to undo the paste in new file and switched back with Ctrl+TAB to large file changes.txt.
                      Second test case was making a large selection with holding Shift on executing command Goto line.
                      1. I pressed Ctrl+G to open Go To dialog, entered 50000 and pressed RETURN to go to line 50000 column 1.
                      2. I pressed Ctrl+G to open Go To dialog once again, entered 250000, pressed and hold left Shift and pressed RETURN to go to line 250000 column 1 with selecting everything from current caret position to new caret position.
                      3. I pressed Ctrl+C, Ctrl+TAB and Ctrl+V to copy and paste the large block into the new file.
                      4. I verified with looking on the line numbers displayed by UltraEdit at end of new file as well as on line number at beginning of last line line and after Ctrl+HOME also of first line in new file if everything was correct and as expected which was the case.
                      5. I pressed Ctrl+Z to undo the paste in new file and switched back with Ctrl+TAB to large file changes.txt.
                      Third test case was making a large selection with holding Shift on executing command Find.
                      1. I pressed Ctrl+G to open Go To dialog, entered 900000 and pressed RETURN to go to line 900000 column 1.
                      2. I inserted here the string #!#!#!.
                      3. I pressed Ctrl+G to open Go To dialog, entered 400000 and pressed RETURN to go to line 400000 column 1.
                      4. I pressed Alt+F3 to open Find, entered as search string #!#!#! and made sure that all find options are set for a normal literal string search.
                      5. I pressed and hold left Shift and pressed RETURN to execute the Find downwards with selecting everything from current caret position to end of found string.
                      6. I pressed Ctrl+C, Ctrl+TAB and Ctrl+V to copy and paste the large block into the new file.
                      7. I verified with looking on the line numbers displayed by UltraEdit at end of new file as well as on line number at beginning of last line line and after Ctrl+HOME also of first line in new file if everything was correct and as expected which was the case.
                      8. I pressed Ctrl+Z to undo the paste in new file, switched back with Ctrl+TAB to large file changes.txt and pressed six times Ctrl+Z to undo inserting #!#!#!.
                      Fourth test case was making a large selection with Shift+PgDn.
                      1. I pressed Ctrl+G to open Go To dialog, entered 20000 and pressed RETURN to go to line 20000 column 1.
                      2. I pressed and hold Shift+PgDn for more than one minute to create a selection up to beginning of line 201607.
                      3. I pressed Ctrl+C, Ctrl+TAB and Ctrl+V to copy and paste the large block into the new file.
                      4. I verified with looking on the line numbers displayed by UltraEdit at end of new file as well as on line number at beginning of last line line and after Ctrl+HOME also of first line in new file if everything was correct and as expected which was the case.
                      Now I closed both files with not saving new file and then opened file C:\Temp\changes.txt once again. I confirmed with pressing RETURN to open the large file with disable temporary files when opening large files (greater than 50 MB) for this edit session only.

                      Then I repeated the four test cases with the difference that no temporary file was used by UltraEdit. The results were the same as before. Every large selection was made as expected and copied and pasted into new file was always the large block as expected.

                      Please let me know the steps you do on which UltraEdit loses parts of a selection while making a large selection.
                      Best regards from an UC/UE/UES for Windows user from Austria