Default font, letters cut off with ClearType enabled on Windows XP (fixed)

Default font, letters cut off with ClearType enabled on Windows XP (fixed)


    Aug 20, 2007#1


    I've noticed that when I use the UltraEdit default font, Courier New/Regular/10 point on Windows XP with ClearType enabled, some letters get cut off.

    For example, I am coding with the Yahoo User Interface. So I have several classes called YAHOO.Widget.TextArea ... etc. Here, the capital O gets cut off followed by .

    I have toggled the Setting this may improve display issues with ClearType fonts on Windows XP, but that has no effect. The issue goes away if I set the Font Quality to Antialiased Quality, but the font is then very ugly.

    Has anyone else experienced this?

    I appreciate the help, Tom


      Aug 20, 2007#2

      Yes I have this problem as well. I have seen it on all of the computers I have used. I went back and forth with tech support trying the obvious things.

      I know what the symptoms are and you can try this out yourself. It is a combination of things. It has to do with UltraEdit's rendering on an XP machine with ClearType enabled (although it can't be blamed on XP since NO other editor I have ever used has done this and I have tried quite a few). But for me it is very specific to the syntax highlighting in my wordfile. The letters just before delimiters for that particular file will be clipped. In your wordfile try looking for the section that defines the highlighting for the type of file you have open. After /Delimiters there will be a list of identified delimiters. Remove the period and save the file just to see if the clipping goes away. Unfortunately, you can't leave it this way because then it will not identify keywords that have a period right after them. No solution.


        Oct 01, 2007#3

        I had a problem like this. It has to do with the rendering widths of text not being the same with ClearType on and off.

        You might want to play with the Settings in Editor Display - Advanced.

        Also change the font that you are using.
        I found Consolas to be the best font if you are coding and use clear type.
        The L vs 1 and 0 (zero) vs O (oh) are excellent.

        Here is a link dump about it: ... nload.aspx ... pic=2499.0

        Getting a font that looks "right" to you is well worth the work. One hour of research saves you a lot of strain, ESPECIALLY if you are using clear type.

        Also don't forget to adjust ClearType for your preferences. ... erToy.mspx

        My Personal preference is Consolas regular 9 with UltraEdit set to the best rendering settings it does.

        Clayton Meisman


          Oct 08, 2007#4

          Yes I tried any setting that has anything remotely to do with the display of text (along with tech support). The only thing that does anything is in Editor Display - Advanced the option Setting this may improve display issues with ClearType fonts on Windows XP. This has no effect on the clipping and frankly sounds like a Kludge by the developers. The real kicker here is that even regular/10 pt/courier new has this clipping problem. You will only see it before delimiters in a syntax highlighted file. Again, this is happening on multiple machines and does not occur with any other text editor (including syntax highlighting ones) that I have tried. I have tried just about every freeware editor on the internet.
          The reason I like this editor is that I do a lot of VHDL so column editing makes my work more efficient. It is one of the few editors that does this alongside Crimson Editor but it has other features that I like. I just hate the fact that a text editor can not properly display TEXT.

          Basic UserBasic User

            Re: Default font, letters cut off with ClearType enabled on Windows Vista (fixed)

            Apr 27, 2008#5

            I found this thread because I was having a problem in Vista. For some reason certain characters (especially capital D and P and B) were getting a bit "chopped" on the right-side curves.

            However, before coming here, I was playing with my preferences, and found that for whatever reason, if I go into the display preferences (right-click desktop, choose Personalize, click "Windows Color and Appearance", then click "Effects") and choose "Standard" instead of "Clear Type" for the method of smoothing screen fonts, the problem went away.

            I'm posting this on the off chance that someone else has the same issue.

            -- The Digital Sorceress


              Aug 13, 2008#6

              I have the exact same problem as described by tlschoenrock

              I just updated to the latest 14.10 release and the problem still exists

              The Setting this may improve display issues with ClearType fonts on Windows XP has no impact whatsoever unless you switch it to no anti-aliasing which is essentially switching ClearType off for UE - and that makes the display somewhat harsher on the eyes and therefore more difficult to work/put up with.

              The problem is a combination of syntax highlighting and the delimiters as previously described, alongside fonts with unsuitable character spacing. (What is unsuitable? I don't know! But some are okay and some aren't!) It is NOT a Windows problem though because if you switch off syntax highlighting the problem does not exhibit in UE.

              Also notice that the syntax highlighting in UE doesn't simply color your code, it somehow changes the spacing of characters ... kerning? ... and I think that is what is causing the issue.

              Not all fonts have the same issue though, so .... I'm on the search for a good font now that due to its own character spacing doesn't have this issue in UE - will report back.

                Re: Default font, letters cut off - list of fonts suitable for programming

                Aug 14, 2008#7

                this is the clear type font released with Vista and other recent MS applications - it is designed specifically for programming and display in Visual Studio. Looks OK but still has the clipping problem in UE. Due to anti-aliasing looks a bit fuzzy at smaller sizes.
       ... x?id=17879

                Raster font 10 pt only. A good choice. Does not cause the UE display problem.

                Again max 10 pt but clearer in my opinion than Triskwelin. Does not cause the UE display problem.
       ... index.html

                Envy Code A/B
                Display is OK, but a little "thin" for my liking, only covers code page 1252 characters. Does not cause the UE display problem.

                Proggy Square
                I tried the slashed zero variant, display is clear, sometimes syntax highlighting hard to see. However font size is fixed and quite small if you are working at a higher screen resolution. Don't try scaling up the True Type version it looks horrid. Does not cause the UE display problem though.

                Pixel Carnage Mono
                There are a few variations of pixel carnage, I quite like the tall version. Character spacing is a little too wide if I am being picky. Its a fixed size also. Does not cause the UE display problem.

                I think Dina is my preferred programming font that avoids the UE display issues.

                There are many websites that list a lot more programming fonts you may find other alternatives, but many of them still end up with "clipped" characters in UE. :(


                  Aug 21, 2008#8

                  Yes there are fonts that don't exhibit the clipping, however, you might as well turn ClearType off. Try using DINA with and without ClearType, there is virtually no difference. All these fonts have pixelation, but the lines are thin so it is not as noticeable. Personally I do not like these fonts. For a few years now IDM has been adding feature upon feature making a bloated program that has caused bugs in some of the basic features that I actually use instead of fixing these old bugs (they broke undoing of an edit while in column mode in the latest - fixed later). The clipping bug exists in version 10 as well; wasn't able to go back any farther. I understand that to sell new versions they have to add features but I think they have spent too much time with features and not enough on improvement.


                    Re: Letters cut off with font Monaco with italic style and different background colors

                    Nov 21, 2013#9

                    Has this issue been resolved?

                    I'm currently using UltraEdit v18.20.0.1020 and I still see this issue, regardless of Font Quality setting:

                    I'm currently using Monaco as my font which is a non proportional, fixed width fount, but see this issue with other fonts.

                    My current workaround is to add a space at the end of the line, but that only works if I remember to do it.
           (37.81 KiB)   133

                    Grand MasterGrand Master

                      Re: Letters cut off with font Monaco with italic style and different background colors

                      Nov 21, 2013#10

                      There is no improvement on this display issue in UE v20.00.0.1054. And I could see also the reason from the view of a Windows programmer.

                      As your ZIP file contains only MONACO.TTF for normal style, there are obviously no TTF files for Monaco for the styles bold, italic and bold + italic. Other monospaced fonts like Courier New are available with 4 files for each style. For Courier New the files are cour.ttf (normal), courbd.ttf (bold), couri.ttf (italic) and courbi.ttf (bold + italic).

                      The Windows font rendering engine uses automatically the right font file depending on the style. The application uses the Windows font library functions to get the width of a character or text to display, and gets in case of a font with a TTF in all 4 styles the correct value as the width of each character is defined in the appropriate font file.

                      In your case with Monaco only available for normal style, using bold or italic forces the Windows font rendering engine to emulate the bold/italic style by drawing the characters different than defined in the font file. This makes characters wider than defined in the font file. But that the characters are drawn with a higher width than defined in the font file can be only seen on last character of a bold/italic text when next character is drawn normally or special background highlighting is used for the bold/italic text.

                      I have attached a collage made from two screenshots, one from UltraEdit and one from Word 2010. Microsoft Word 2010 on my Windows 7 computer fails also to recognize the width of italic Monaco correct which is not really surprisingly for me now knowing the facts about the used font. As you can also see by measuring the pixels, the width of normally drawn off is much smaller than the real width of italic drawn off, but UE and Word draw the background for both off with the same width. In other words every italic Monaco character is drawn partly over the area of the next character.

                      What MS Word makes obviously better than UltraEdit is the order of drawing the background areas. Word first draws the page color (white), than the color of the paragraph (yellow) and last the text with its color and background color. It looks like UltraEdit draws first the text and next draws every area not displaying a text or anything else with the background color for plain text in this case. This drawing order results in a chopped character if an italic character is at end of a line. This is something the IDM developers could improve regarding to this display issue.

                      But the real reason for the drawing issue cannot be solved by the IDM developers as a font not designed for bold or italic style will always return the wrong width to the application.

                      IDM strongly recommends to use a fixed pitch font when using bold and italic styles. A fixed pitch font is a monospace font where all characters in all styles have the same width, not just within one style. So a fixed pitch font is a font where for example a normal i has the same width as a bold or italic W. That is not only important for UltraEdit on drawing the text correct. It is also important for a progammer who wants to use bold and italic style as no programmer wants for example a commented source code line in italic displayed different than the same source code line above not commented and therefore drawn normal just because of normal characters are smaller than the italic characters. Courier New and Consolas are both fixed pitch fonts.
                      monaco_italic.png (7.32KiB)
                      Collage of text display in UltraEdit and Word 2010 with normal and italic Monaco
                      Best regards from an UC/UE/UES for Windows user from Austria

                      Basic UserBasic User

                        Re: Double quote cut off with font Lucida Console with italic style

                        Nov 22, 2013#11

                        I have had a similar problem in version 20 with Lucida Console, a monospaced font. The theme that I use, Twilight, defaults to italics for quoted strings. If the last character in a line is a double quote, in Lucida Console it appears as a single quote, with just a pixel or two of the second quote mark showing. Courier New and Consolas (which I now use) don't have that problem, and I haven't noticed any problems in Lucida Console except the double quotes (but that's enough to make it pretty much unusable for programming). Looking at it more closely, I see that Lucida Console does not seem to have an actual italic font style, but uses a style called oblique.

                        Basic UserBasic User

                          Re: Letters cut off with font Consolas with ClearType enabled on Windows 7 using UE v15.20

                          Feb 26, 2016#12

                          I know this is an old post but I'm experiencing this issue too with the Consolas font. I'll confirm what tlschoenrock found (back in 2007!) except that this issue still exists with Windows 7.

                          I'm using an old version of UE ( so it's probably more to do with that than the OS. However, I'm hoping that my company will upgrade to the latest version of UE soon and wondered if anyone could confirm whether this issue is still present in more recent versions? From Calab's note from 2013, the issue still seemed to be present in

                          Consolas seems to be the best font overall for my purposes (I was using Lucida Console which doesn't appear to suffer on the cutting issue but, unfortunately, doesn't distinguish between upper-case letter o and zero very well).

                          Any update that anyone can give would be appreciated.

                          Thanks, PG
                          UltraEdit version and OS info:
                          UltraEdit;Windows 7

                          Grand MasterGrand Master

                            Re: Default font, letters cut off with ClearType enabled (fixed)

                            Feb 27, 2016#13

                            From file changes.txt in program files folder of UltraEdit:

                            • Much improved font rendering (predominantly with Clear-Type fonts)
                              • Font, Printer Font, Hex/Col Font, Reset Font
                            The configuration setting Setting this may improve display issues with ClearType fonts on Windows XP was also removed in UE v16.20 and UES v10.20 as not needed anymore.

                            • Font quality improvements
                              • Addressed clipping issues
                              • Improved quality at different point sizes
                              • Better rendering of font styles (bold, italic, etc.)
                            • Framework/display improvements
                              • Ability to set font sizes in file tabs and child windows
                            • Full support for proportional fonts
                              • Corrected caret positioning issues with fonts that are not fixed-width
                              • Improved syntax highlighting for fonts that are not fixed-width
                            • Set Output Window font separately from other child window fonts (right-click in Output Window)
                            The issue reported by Calab was caused by using a true type font which is available only in regular style, but using this font also in italic style. No text editor or word processing application can really handle this, although this issue is most often not seen because of identical background color for all areas in document window. Consolas is available in regular, bold, italic and bold italic and can be downloaded from Consolas Font Pack for Microsoft Visual Studio 2005 or 2008. So the italic letter cut off by different background color issue reported by Calab does not occur on using Consolas.
                            Best regards from an UC/UE/UES for Windows user from Austria

                            Basic UserBasic User

                              Re: Default font, letters cut off with ClearType enabled (fixed)

                              Feb 29, 2016#14


                              Thank you as usual for your response. When (if?) I get UE upgraded I will confirm whether this issue has been resolved.


                              UltraEdit version and OS info:
                              UltraEdit;Windows 7