Adding Wordfile for Mac

Adding Wordfile for Mac

1

    Feb 29, 2016#1

    Hi,

    I am using UltraEdit 16.0.0.4 on a Mac and cannot figure out how to add wordfiles.

    I find that UE is installed in my Applications folder and that if I right-click on the app and "Show Package Contents" I can locate the word files in Contents/Resources/wordfiles. I copy my .uew file there, restart UE but the file does not show up in the list.

    What do I need to do to get the new wordfile to load?

    Thanks in advance!

    Michael

    6,654559
    Grand MasterGrand Master
    6,654559

      Feb 29, 2016#2

      I don't have a Mac and therefore don't use UltraEdit for Mac. But I suppose that what I have written in Readme for the Syntax Highlighting forum is also true for UEX and UEM. The wordfiles subdirectory in application directory is for the installer, the wordfiles subdirectory in user's home directory is for what is really used by UltraEdit.

      See Wordfile storage on Linux (CentOs) because the information for UE for Linux are better for UE for Mac than those for UE for Windows.
      Best regards from an UC/UE/UES for Windows user from Austria

      1

        Sep 03, 2016#3

        I'm using UE Version: 16.10.0.10 under El Capitan on a Mac Pro 2013 Trashcan.
        I've downloaded a wordfile for Arduino from https://www.ultraedit.com/downloads/ext ... files.html

        The file name is arduino.uew (surprise!).

        Just by inspection I can see that there are two places where wordfiles occur:

        /Applications/UltraEdit.app/Contents/Resources/arduino.uew
        and
        /Users/andy/Library/Application Support/UltraEdit/wordfiles/arduino.uew

        I've put copies of the file in both places and restarted UE (several times) but I do not see the Arduino file being presented when I use View As (Highlighting....).

        I've done numerous Google searches but there doesn't seem to be anything else I need to do.

        Is this is a known bug, please? Or is there indeed some ritual I have failed to do? For example, do I have to sacrifice a goat or something to make it work? (I used to use Windows and I went through a lot of goats...)   :wink:  

        Thanks
        Andy

        6,654559
        Grand MasterGrand Master
        6,654559

          Sep 03, 2016#4

          There is not the name of the wordfile displayed in View As submenu. The menu item has the name of the syntax highlighting language defined in the user contributed wordfile arduino.uew. The syntax highlighting language name is defined in first line of the wordfile after /L20 in double quotes. Wordfile arduino.uew defines PDE/INO as language name. So look for that name in View As submenu. Of course the language name can be changed for example to Arduino if you think that is a better language name.

          UltraEdit for Windows has in configuration (settings/preferences) the tree item Editor Display with subitem Syntax Highlighting. There the user can define the directory for the *.uew files and there is also displayed the currently used directory. So if UltraEdit for Mac has also a syntax highlighting preferences dialog which I don't know as not using UEM (don't have a Mac), look in this dialog if there is the directory path displayed to know where UEM is searching for *.uew files.
          Best regards from an UC/UE/UES for Windows user from Austria

          1
          NewbieNewbie
          1

            Oct 27, 2016#5

            Folks,

            Here is what worked for me on the Mac:
            • Navigate to UltraEdit > Preferences > Display > Syntax Highlighting
            • Click "open" to open one of the existing files.

              Note that the file is located here:

              /Users/<user>/Library/Application Support/UltraEdit/wordfiles
            • Copied my files here and they are working.

            1
            NewbieNewbie
            1

              Sep 19, 2017#6

              Hello all,

              I followed all the suggestions from this page.

              However, I can not find the folder of

              /Users/<user>/Library/Application Support/UltraEdit/wordfiles.

              Is anyone also encounter this problem?

              Also, is the IDM team still working on solving this problem?

              6,654559
              Grand MasterGrand Master
              6,654559

                Sep 19, 2017#7

                Finder on Mac OS hides the directories in which applications store user configurations as Windows Explorer does by default on Windows most likely for preventing users to unintentionally delete configuration files of used applications.

                I copied the instructions from this post on how to find the application data directory using Finder on Mac.
                • Open Finder.
                • Hold the option key and select Go at the top of the screen. This step is very important.
                • Choose Library (this will not show unless you are holding the option key).
                • Choose Application Support.
                • You should see an UltraEdit folder, open it.
                • You should see the subfolder wordfiles.
                On Windows the application data directory has by default the hidden attribute set .For that reason on running a find with Windows Explorer with default settings this directory with all its subdirectories is not found because Windows Explorer by default ignores hidden directories and files on search. The solution is copying the file path as displayed in Syntax Highlighting configuration dialog to clipboard, pasting it into the address bar of Windows Explorer and hitting key RETURN to open the folder in Windows Explorer. Another possibility on Windows is copying %APPDATA%\IDMComp\UltraEdit\wordfiles to clipboard and pasting it into address bar, or entering directly this path with the environment variable reference in the address bar, and hitting key RETURN to open the folder. The application data folder in folder path has by default the hidden attribute set for not displaying this folder and all its subfolders by default.

                I don't have a Mac. But I assume on Mac the same methods work. So instead of searching for the folder, the folder path must be directly entered either by copying and pasting the path as shown in Syntax Highlighting preferences dialog, or by entering ~/Library/Application Support/UltraEdit/wordfiles directly.
                Best regards from an UC/UE/UES for Windows user from Austria