How to change Read-Only file attribute from within UltraEdit?

How to change Read-Only file attribute from within UltraEdit?

5
NewbieNewbie
5

    Sep 26, 2011#1

    Hello,

    I am using version 17.20.0.1016 of UltraEdit and when a file is opened that is Read-Only there is a icon indicator and the background indicates such. My question is, is there a way to change the file from Read-Only to Write/Read? I searched around, but my google fu is not strong this morning.

    Thanks,
    Mark

    901
    MasterMaster
    901

      Sep 27, 2011#2

      The Explorer pane allows you to access/change file properties including the read-only flag.

      Also, under the Edit drop-down menu you can toggle "read-only" mode. This doesn't change the attribute on the file, but it does enable editing in the edit pane. After editing, you can trigger a Save As then right click on the original file in the Save As dialog to access it's file properties and turn off the read-only flag, then overlay the file.

      6,603547
      Grand MasterGrand Master
      6,603547

        Sep 27, 2011#3

        There is the configuration setting Change file read-only attribute when changing menu setting at Advanced - Configuration - File Handling - Miscellaneous. If this setting is enabled, executing Edit - Read Only results in removing the read-only attribute of the file and you can edit the file. Once finished with editing and file is saved, execute Edit - Read Only again to set the read-only attribute and close the file.

        And it is also possible to open Advanced - DOS Command, enter as command attrib -r "%f" and execute the command. UltraEdit detects with the default settings the change on the file attributes and asks for reloading the active file which you must confirm. After closing also opened Command Output window you can edit now the file.

        5
        NewbieNewbie
        5

          Sep 27, 2011#4

          Mofi / Bulgrien,

          thanks for the great info. With the info I was able to find and add an option to the right click menu for a tab then added the "Read Only" command. This works great, for what I would like to do. THANKS!!!

          Mark