Wider application window border width results in wrong display of ribbon with UE v25 and v26

Wider application window border width results in wrong display of ribbon with UE v25 and v26

27
Basic UserBasic User
27

    May 15, 2019#1

    I've start my new job a few month ago. Then I'd want to install UE on my new PC. But, I figured out that UE is not correctly displayed. 
    The problem is shown on the following snapshot:

    ue_display_ko.png (26.54KiB)

    I talk about the wide gray border around the application window of UltraEdit running on Windows 7.

    I've the same problem with version v25.20 and with version v26.00.
    I tried to uninstall the version, clean folders and reinstall UE. However, the problem is still there.

    For information I work on a laptop (integrated Intel video) with a second monitor (1080p).

    Thanks for your help.

    6,601547
    Grand MasterGrand Master
    6,601547

      May 15, 2019#2

      Please take a look on What are the elements in UltraEdit window with colors defined by Windows and not by UltraEdit theme?

      It looks like the ActiveBorder respectively on your screenshot the Inactive Window Border is defined in your Windows Classic desktop theme settings to have the RGB colors 180 180 180 (B4B4B4). The active/inactive window border width is defined with four (or five?) pixels instead of just one pixel which is not recognized by UltraEdit because of this wider than usual window border width reduces the window client area width for the application.

      The ButtonFace (3D objects) color is defined perhaps also with the RGB colors 180 180 180 (B4B4B4) and width is one pixel as by default.

      In total those two borders are responsible for gray frame border with a width of five pixels.

      I suggest to look in Windows 7 desktop settings on configured width for Active/Inactive Window Border and set it to 1 if the value is currently 4 (or 5).

      Please save your Windows 7 desktop theme settings into a Windows *.theme file and uploaded this file and also the UltraEdit theme file *.ue-theme currently used by you as attachments to your next post if changing the width of active/inactive window border does not solve the issue.
      Best regards from an UC/UE/UES for Windows user from Austria

      27
      Basic UserBasic User
      27

        May 22, 2019#3

        Hi,

        Well I've tried what you say, but I don't see any change. 
        What I find weird is that I see this "bug" only with UE.

        As you asked, I contribute my Windows theme and my UE (classic) theme.
        Win7_UE_wimille.theme (3.69 KiB)   0
        Theme_UE_wimille.ue-theme (34.9 KiB)   0

        6,601547
        Grand MasterGrand Master
        6,601547

          May 22, 2019#4

          You see this issue only with UE because of UltraEdit with your theme settings is most likely the only application using Microsoft's libraries with ribbon interface and Windows Classic desktop theme settings and use also Classic theme settings in application window. I am not aware of any application which gives the user the possibility to use such a combination of theme settings.

          However, I could quickly see with your theme files what is causing the wider frame border. It is the Border Padding with value 4 instead of default value 0 in your Windows 7 desktop theme settings. The attached ZIP file contains file UE_winmille_no_padding.theme with your Windows 7 theme with Border Padding set to 0.

          The ZIP file contains additionally ue_border_padding_4.png showing UltraEdit main application window as displayed with your theme settings on my Windows 7 computer. There is no overlapping of the inner area by wider frame border. The second image file ue_border_padding_0.png in ZIP file contains the look of UE main window with your UltraEdit theme file with Border Padding set to 0.

          It is strange that with your Windows 7 desktop theme or with my Windows 7 desktop theme being also a Windows classic theme the UltraEdit main icon at top left edge of application window is not drawn in title bar on using your UE theme, or UltraEdit Classic theme, or my UltraEdit custom theme while it is drawn with using Slate theme of UltraEdit. But the main application icon is missing only on using ribbon interface. The main application icon is visible with any UE theme on using toolbar/menu mode which is my preferred UltraEdit interface mode for several reasons.
          theme_and_images.zip (67.58 KiB)   0
          The ZIP file contains Windows 7 theme with border padding 0 and two screenshots of UltraEdit main application window.
          Best regards from an UC/UE/UES for Windows user from Austria

          27
          Basic UserBasic User
          27

            Jun 03, 2019#5

            Hi

            Thank you Mofi, it is better now.
            Not perfect but much better. However, with a dark theme on UE it's still anoying. But i can use UE as it is.