[WORKAROUND found]- SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite

[WORKAROUND found]- SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite

8
NewbieNewbie
8

    Feb 17, 2015#1

    Hi,

    i simply tried to "sort" (using first field) a very simple csv file, but without success.
    Is this a bug ?

    here is my sample :
    4,test,uu
    2,test,yy
    1,test,rr
    12,test,xx

    I proceeded like this :
    Transform it in fixed columns
    used a comma separator (,)
    used Start key field =1, Start character =1, End key Filed=1, End character =0

    Could someone let me know it it's a bug for the Mac (yosemite) version ??
    Regards

      Re: SORT issue - Version 15.0.0.11 for Mac OS Yosemite (solved)

      Feb 17, 2015#2

      Even the basic "Sort" doesn't work :-(

      Am i doing something wrong ??!

      Regards,

        Re: SORT issue - Version 15.0.0.11 for Mac OS Yosemite (solved)

        Feb 17, 2015#3

        the output results are :

        SORT SUCCESSFUL: /Users/aferreira/.idm/99F040E7-E3CA-4B2F-9834-B8A1803A871F1910aferreira/testQVtmaq
        Trier[1949] processus terminé

        6,626551
        Grand MasterGrand Master
        6,626551

          Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

          Feb 17, 2015#4

          In UltraEdit for Windows a sort based on entire line must be done with Key 1 configured: Start column = 1 , End column = -1

          Start column = 1 and end column = 0 as you have used does not make much sense to me.
          Best regards from an UC/UE/UES for Windows user from Austria

          8
          NewbieNewbie
          8

            Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

            Feb 17, 2015#5

            Hi Mofi doesn't work either :-(

            With windows in works like this: Advanced File Sort: Column-Based Sort (UltraEdit for Windows)
            With Linux/Unix/Mac OS like this: Sort files in UltraEdit for Linux

            So if you want to sort the file below (csv):

            Code: Select all

            4 ,test,uu
            2 ,test,yy
            1 ,test,rr
            12,test,xx
            You will have to specify that you want to sort it using "field 1" (or column 1 with windows) -> Start field = 1, End field = 1
            Then to say which characters you want to use to sort it, you have to define : Start character = 1, End character = 0 (0 = until the end of the field)

            I'm afraid this is a bug ... :-(

            Someone who uses Mac succeeded to make it work?

            6,626551
            Grand MasterGrand Master
            6,626551

              Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

              Feb 18, 2015#6

              Ah, sort in UE for Linux/Mac works completely different in comparison to UE for Windows. Thanks for letting me know.

              Your advanced sort options look right. But I suppose the sort is strictly a string based sort and not a numeric sort even when using field values for sort and a field just contains a number with leading or trailing spaces. So you will not get a numeric sort on field value 1 as I think you want. The posted 4 lines would be correct if sort is descending on field value 1 (or entire line) for a string sort.

              Running a Perl regular expression Replace All from top of file with search string ^(\d+)( +) and replace string \2\1 would change left alignment of the numbers in first field to right alignment.

              Code: Select all

               4,test,uu
               2,test,yy
               1,test,rr
              12,test,xx
              Now running an ascending sort on entire line or just field value 1 should result in:

              Code: Select all

               1,test,rr
               2,test,yy
               4,test,uu
              12,test,xx
              Best regards from an UC/UE/UES for Windows user from Austria

              8
              NewbieNewbie
              8

                Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

                Feb 18, 2015#7

                Hi Mofi, yep using a script it works.

                But for more convenience would like it to be a OOTB UE function :-)
                I opened a case with the support.

                Will let you know...
                Cheers,

                  Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

                  Feb 18, 2015#8

                  All, here is the feedback from UE support :


                  Thank you for your response and the additional information. I have configured my system as you've described here and have confirmed that this doesn't work in the French version of UEX. I'm not sure why this is, but I will ask our developers to correct this and will let you know as soon as we have an updated build that we believe addresses this issue.

                    Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

                    Feb 18, 2015#9

                    WORKAROUND :

                    I changed my language settings in System Preferences (Mac OS) :

                    English (first)
                    French (second)

                    Then I restart UEX and the UEX menu changed to English, and "sort" feature worked perfectly.
                    In the meantime, the developers will patch the French version.

                    Regards,

                    6,626551
                    Grand MasterGrand Master
                    6,626551

                      Re: SORT doesn't work - Version 15.0.0.11 for Mac OS Yosemite (solved)

                      Feb 19, 2015#10

                      Excellent analysis of the issue and also excellent reporting. Many thanks. I think, many users of non English UEX running in same sort problem will find this topic very useful.
                      Best regards from an UC/UE/UES for Windows user from Austria