Problem with "Auto indent wrapped lines" in UE 30.2.0.41

Problem with "Auto indent wrapped lines" in UE 30.2.0.41

11
Basic UserBasic User
11

    1:04 - Apr 09#1

    In UltraEdit v.30.2.0.41 when option Configuration - Editor display - Formatting - Auto indent wrapped lines is checked, Word wrap is ON and wrapped line begin with spaces, clicking with mouse on wrapped part of line (second, third e.t.c. rows) move keyboard cursor right of click position with length of spaces in the begin of the line. In UltraEdit v.30.2.0.27 and earlier this problem not exist - click on wrapped part of line move keyboard cursor right to point of click. Problem persist in x64 version of program under both Win 7 x64 and Win 10 x64, x86 version is not tested.

    6,651559
    Grand MasterGrand Master
    6,651559

      13:21 - Apr 14#2

      I could reproduce this issue as written by you. I report usually not an issue detected by somebody else by email to UltraEdit support. But the issue is quite new and reproducible also with UltraEdit 2024.0 Beta 3. I decided for that reason reporting it by email to UltraEdit support. I recommend doing the same. The more users report an issue the higher becomes the priority for fixing the issue.

      Here is what I have just sent a few minutes ago:

      There is a display issue reported by a user in forum, see the topic: https://forums.ultraedit.com/viewtopic.php?f=2&t=19486

      The caret (text cursor) is displayed at the wrong position on an automatically indented soft-wrapped line after a mouse click for positioning the caret in the long line.

      Do the following for reproducing the issue:
      1. Open the attached file Caret_Position_Test_File.txt in UltraEdit.
      2. Enable in the configuration at Editor display - Formatting the configuration settings Auto indent new lines and Auto indent wrapped lines.
      3. Make sure the configuration setting Wrap at window edge is selected at Editor - Word wrap / tab settings for list item Default and close the configuration dialog window.
      4. Enable word-wrap on the opened file Caret_Position_Test_File.txt.
      5. Click with the primary (usually left) pointing device (mouse) button somewhere in the middle of second, third or fourth displayed line.
      There can be seen that the caret (text cursor) is not blinking at the clicked position. The caret is blinking eight characters to the right. See the attached image file Caret_Position_Indented_Wrapped_Line.png.

      Pressing now on keyboard first LEFT ARROW and next RIGHT ARROW results in a blinking text cursor at the initially clicked position on the auto-indented
      wrapped line.

      This issue is reproducible with:
      • UltraEdit 2024.0.0.21 64-bit (Beta 3) on 64-bit Windows 11 23H2
      • UltraEdit 2023.2.0.41 64-bit on 64-bit Windows 11 23H2
      • UltraEdit 2023.2.0.41 32-bit on 64-bit Windows 7 SP1
      • UltraEdit 2023.2.0.33 32-bit on 64-bit Windows 7 SP1
      This display issue is not reproducible with UltraEdit 2023.2.0.27 and former versions of UltraEdit for Windows.

      There is no problem with clicking somewhere on the soft-wrapped lines of third line in the file with no indent spaces on the displayed lines of the long line. The issue does not exist on having not checked the setting Auto indent wrapped lines in the configuration.
      Caret_Position_Test_File.txt (755 Bytes)   0
      text file for reproducing the display issue
      Caret_Position_Indented_Wrapped_Line.png (3.77KiB)
      screenshot showing the display issue
      Best regards from an UC/UE/UES for Windows user from Austria